summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-misc/heyu/ChangeLog4
-rw-r--r--app-misc/heyu/Manifest6
-rw-r--r--app-misc/heyu/heyu-2.6.0.ebuild83
-rw-r--r--app-misc/heyu/heyu-2.7.0.ebuild80
4 files changed, 87 insertions, 86 deletions
diff --git a/app-misc/heyu/ChangeLog b/app-misc/heyu/ChangeLog
index de2e88e12..6801a889d 100644
--- a/app-misc/heyu/ChangeLog
+++ b/app-misc/heyu/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 30 Jun 2009; Sven Schwyn (svoop) <gentoo@bitcetera.com>
+ -heyu-2.6.0.ebuild, +heyu-2.7.0.ebuild:
+ Version bump for bug 91396
+
09 May 2009; Christian Ruppert <idl0r@gentoo.org> heyu-2.6.0.ebuild:
Use EPI 2. Use src_configure instead of src_compile. sed and
domanimproved, readability.
diff --git a/app-misc/heyu/Manifest b/app-misc/heyu/Manifest
index edf685566..ade300832 100644
--- a/app-misc/heyu/Manifest
+++ b/app-misc/heyu/Manifest
@@ -1,5 +1,5 @@
AUX heyu.init 423 RMD160 96dd75247188abdb8847807863c1cf2952c54279 SHA1 aac324ffc55a7ec20055ce5af6340372a892b853 SHA256 aee16c73a380015858137f7bbc0f1944727ddd82403bc7b2734d291855d0a9a9
-DIST heyu-2.6.0.tgz 518189 RMD160 22918f6c70c54f5754e1f04a02e9a38a0a5d24ac SHA1 18f6cccb6a98519da077814d26ab1b59960df514 SHA256 1284e793520d2e152d9d7032f6727e72fbaaf7c4f4eaf9abea2b85eed090b0d2
-EBUILD heyu-2.6.0.ebuild 2896 RMD160 efebfdc4c1a1406f13a8f09e94a6cec4ed43ed70 SHA1 eef723524e001eddf1e18001f1abc7fb63a0e06c SHA256 2d1f5caeff41eb5c283ed6528de73eb9d2f4d03d7b2164280daa341d93601273
-MISC ChangeLog 1634 RMD160 44f695a74f68121fa6b46e1d1e56352d5f483225 SHA1 9da18bfbfbbae5e9d26a5872cea927da728abc54 SHA256 d1e9dc7a7640f85d41f77ea8b19f82f700e21e1ff059b3b512539c9bcc89e4bd
+DIST heyu-2.7.0.tgz 538676 RMD160 1f208ff917d4bf126afa2e113bcc8bd008654776 SHA1 fdd35b10730036842b023108a69c3c33d73c5ebf SHA256 4ad5127da2cd314ba022481dc266eda45253046f8340f6f6b427e7a1a362ba2b
+EBUILD heyu-2.7.0.ebuild 3528 RMD160 896853258169222ba5625c184b0cc7381ee61699 SHA1 54e864ae9fd3200cba9ee499b097cb234862fb70 SHA256 eac4915535db2b288c3c8182f549ad87bf3940d7f790c74a41bd0da8ba0c249a
+MISC ChangeLog 1764 RMD160 7ee3d8cf424a22c4ecb69eea6501ed35db305058 SHA1 808d637b30a542ea447bdb514474ab85318da4b5 SHA256 478b29fdd5e2a03f0ab0c508071f04502cc14aff5070c2543146a6f754f73e70
MISC metadata.xml 1225 RMD160 9cc4a306989b21aadc2c46cbe77b49d94f5f7531 SHA1 01b5d2dfc5446f495689a0d1a8357982464e54fb SHA256 9b9ac8546a69802b4de3818d06e98c4738485d6634fb6375f087cb1ae2853a07
diff --git a/app-misc/heyu/heyu-2.6.0.ebuild b/app-misc/heyu/heyu-2.6.0.ebuild
deleted file mode 100644
index a6ea970e7..000000000
--- a/app-misc/heyu/heyu-2.6.0.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="2"
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="Utility to control and program CM11A, CM17A and CM12U X10 interfaces"
-HOMEPAGE="http://heyu.tanj.com"
-SRC_URI="http://heyu.tanj.com/download/${P}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="kernel_Darwin kernel_FreeBSD kernel_linux cm17a dmx210 ext0 ore rfxm rfxs"
-
-pkg_setup() {
- enewgroup ${PN}
- enewuser ${PN} -1 -1 /var/lib/${PN} "${PN},uucp"
-}
-
-src_configure() {
- mv x10config.sample x10.conf.sample
- ./Configure \
- $(use kernel_FreeBSD && echo "freebsd") \
- $(use kernel_Darwin && echo "darwin") \
- $(use kernel_linux && echo "linux") \
- $(use cm17a || echo "-nocm17a") \
- $(use dmx210 || echo "-nodmx") \
- $(use ext0 || echo "-noext0") \
- $(use ore || echo "-noore") \
- $(use rfxm || echo "-norfxm") \
- $(use rfxs || echo "-norfxs") \
- || die "configure failed"
-
- sed -i -r -e "s/CC\s*=.*/CC = $(tc-getCC)/" \
- -e "s/CFLAGS\s*=.*/CFLAGS = ${CFLAGS} \$(DFLAGS)/" \
- -e 's%^(DFLAGS.+)-DSYSBASEDIR=\\"[^\]+\\"%\1%' \
- -e 's%^(DFLAGS\s*=\s*)%\1-DSYSBASEDIR=\\"/var/lib/heyu\\" %' \
- -e 's%^(DFLAGS.+)-DSPOOLDIR=\\"[^\]+\\"%\1%' \
- -e 's%^(DFLAGS\s*=\s*)%\1-DSPOOLDIR=\\"/var/lib/heyu\\" %' \
- -e 's%^(DFLAGS.+)-DLOCKDIR=\\"[^\]+\\"%\1%' \
- -e 's%^(DFLAGS\s*=\s*)%\1-DLOCKDIR=\\"/var/lock\\" %' Makefile \
- || die "adjusting Makefile failed"
-
- sed -i -r 's%(LOG_DIR.*?)NONE%\1/var/log/heyu%' x10.conf.sample || die "changing LOG_DIR failed"
-}
-
-src_install() {
- dobin heyu || die "installing binary failed"
- doman heyu.1 x10{config,scripts,sched}.5 || die "installing man pages failed"
- newinitd "${FILESDIR}"/heyu.init heyu || die "newinitd failed"
-
- insinto /etc/heyu
- doins x10.*.sample || die "installing config samples failed"
-
- diropts -m 0750 -o heyu
- dodir /var/log/heyu || die "creating log directory failed"
-
- dosym /etc/heyu/x10.conf /var/lib/heyu/x10.conf || die "dosym failed"
- dosym /etc/heyu/x10.sched /var/lib/heyu/x10.sched || die "dosym failed"
-}
-
-pkg_postinst() {
- elog "Don't forget to tell heyu where to find your CM11 or CM17. Therefore"
- elog "the file /etc/heyu/x10.conf must contain a line starting with 'TTY'"
- elog "followed by the corresponding device such as:"
- elog
- elog "TTY /dev/ttyS0 <-- on first serial port"
- elog "TTY /dev/ttyS1 <-- on second serial port"
- elog "TTY /dev/ttyUSB0 <-- on USB port"
- elog
- elog "To use your device on a USB port, the corresponding USB serial converter"
- elog "kernel module must be loaded. Older CM11 are usually delivered with a"
- elog "a Prolific 2303 cable (kernel module: pl2303) while newer come with a"
- elog "FTDI cable (kernel module: ftdi_sio)."
- elog
- elog "Execute the following command if you wish to start the HEYU daemon"
- elog "at boot time:"
- elog
- elog "rc-update add heyu default"
-}
diff --git a/app-misc/heyu/heyu-2.7.0.ebuild b/app-misc/heyu/heyu-2.7.0.ebuild
new file mode 100644
index 000000000..5fe84cb85
--- /dev/null
+++ b/app-misc/heyu/heyu-2.7.0.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Utility to control and program CM11A, CM17A and CM12U X10 interfaces."
+HOMEPAGE="http://heyu.tanj.com"
+SRC_URI="http://heyu.tanj.com/download/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="kernel_Darwin kernel_FreeBSD kernel_linux cm17a dmx210 ext0 ore rfxm rfxs"
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 /var/lib/${PN} "${PN},uucp"
+ ewarn "Heyu must not be running when updating to a higher version as"
+ ewarn "stray lockfiles may prevent it from restarting - in which case"
+ ewarn "you should refer to the cleanup section of the Heyu man page."
+ epause
+}
+
+src_compile() {
+ mv x10config.sample x10.conf.sample
+ "${S}"/Configure \
+ $(use kernel_FreeBSD && echo "freebsd") \
+ $(use kernel_Darwin && echo "darwin") \
+ $(use kernel_linux && echo "linux") \
+ $(use cm17a || echo "-nocm17a") \
+ $(use dmx210 || echo "-nodmx") \
+ $(use ext0 || echo "-noext0") \
+ $(use ore || echo "-noore") \
+ $(use rfxm || echo "-norfxm") \
+ $(use rfxs || echo "-norfxs") \
+ || die "configure failed"
+ sed -i "s/CC\s*=.*/CC = $(tc-getCC)/" "${S}"/Makefile || die "adjustment of CC failed"
+ sed -i "s/CFLAGS\s*=.*/CFLAGS = ${CFLAGS} \$(DFLAGS)/" "${S}"/Makefile || die "adjustment of CFLAGS failed"
+ sed -i -r 's%^(DFLAGS.+)-DSYSBASEDIR=\\"[^\]+\\"%\1%' "${S}"/Makefile || die "removing DSYSBASEDIR from DFLAGS failed"
+ sed -i -r 's%^(DFLAGS\s*=\s*)%\1-DSYSBASEDIR=\\"/var/lib/heyu\\" %' "${S}"/Makefile || die "adding DSYSBASEDIR to DFLAGS failed"
+ sed -i -r 's%^(DFLAGS.+)-DSPOOLDIR=\\"[^\]+\\"%\1%' "${S}"/Makefile || die "removing DSPOOLDIR from DFLAGS failed"
+ sed -i -r 's%^(DFLAGS\s*=\s*)%\1-DSPOOLDIR=\\"/var/lib/heyu\\" %' "${S}"/Makefile || die "adding DSPOOLDIR to DFLAGS failed"
+ sed -i -r 's%^(DFLAGS.+)-DLOCKDIR=\\"[^\]+\\"%\1%' "${S}"/Makefile || die "removing DLOCKDIR from DFLAGS failed"
+ sed -i -r 's%^(DFLAGS\s*=\s*)%\1-DLOCKDIR=\\"/var/lock\\" %' "${S}"/Makefile || die "adding DLOCKDIR to DFLAGS failed"
+ sed -i -r 's%(LOG_DIR.*?)NONE%\1/var/log/heyu%' "${S}"/x10.conf.sample || die "changing LOG_DIR failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ dobin heyu || die "installing binary failed"
+ doman heyu.1 x10config.5 x10scripts.5 x10sched.5 || die "installing man pages failed"
+ newinitd "${FILESDIR}"/heyu.init heyu
+ insinto /etc/heyu
+ doins x10.*.sample || die "installing config samples failed"
+ diropts -m 0750 -o heyu
+ dodir /var/log/heyu || die "creating log directory failed"
+ dosym /etc/heyu/x10.conf /var/lib/heyu/x10.conf
+ dosym /etc/heyu/x10.sched /var/lib/heyu/x10.sched
+}
+
+pkg_postinst() {
+ elog "Don't forget to tell heyu where to find your CM11 or CM17. Therefore"
+ elog "the file /etc/heyu/x10.conf must contain a line starting with 'TTY'"
+ elog "followed by the corresponding device such as:"
+ elog
+ elog "TTY /dev/ttyS0 <-- on first serial port"
+ elog "TTY /dev/ttyS1 <-- on second serial port"
+ elog "TTY /dev/ttyUSB0 <-- on USB port"
+ elog
+ elog "To use your device on a USB port, the corresponding USB serial converter"
+ elog "kernel module must be loaded. Older CM11 are usually delivered with a"
+ elog "a Prolific 2303 cable (kernel module: pl2303) while newer come with a"
+ elog "FTDI cable (kernel module: ftdi_sio)."
+ elog
+ elog "Execute the following command if you wish to start the HEYU daemon"
+ elog "at boot time:"
+ elog
+ elog "rc-update add heyu default"
+}