summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/apt-cacher-ng/ChangeLog5
-rw-r--r--net-misc/apt-cacher-ng/Manifest5
-rw-r--r--net-misc/apt-cacher-ng/apt-cacher-ng-0.3.11.1.ebuild105
3 files changed, 114 insertions, 1 deletions
diff --git a/net-misc/apt-cacher-ng/ChangeLog b/net-misc/apt-cacher-ng/ChangeLog
index 690ec8c9a..e26a2fd12 100644
--- a/net-misc/apt-cacher-ng/ChangeLog
+++ b/net-misc/apt-cacher-ng/ChangeLog
@@ -2,6 +2,11 @@
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*apt-cacher-ng-0.3.11.1 (10 May 2009)
+ 10 May 2009; Sergey Dryabzhinsky <sergey.dryabzhinsky@gmail.com>
+ +apt-cacher-ng-0.3.11.1.ebuild
+ Version bump
+
*apt-cacher-ng-0.3.10.1 (08 May 2009)
08 May 2009; Sergey Dryabzhinsky <sergey.dryabzhinsky@gmail.com>
+apt-cacher-ng-0.3.10.1.ebuild
diff --git a/net-misc/apt-cacher-ng/Manifest b/net-misc/apt-cacher-ng/Manifest
index 4c41e36e7..006e362f2 100644
--- a/net-misc/apt-cacher-ng/Manifest
+++ b/net-misc/apt-cacher-ng/Manifest
@@ -5,6 +5,9 @@ AUX initd 785 RMD160 56dd07e923ef664e8fd192d6a153f2b922ee4835 SHA1 eef235be0317b
AUX logrotate 377 RMD160 ef3824ff3484b00195fad7153332ce33f702d937 SHA1 d5606fceb5f3296aff7a7111ffadb440761286f2 SHA256 6f1624d655383452a6d56d69327d41b80379cc667ad2d481ca94f8ea78f7a65b
DIST apt-cacher-ng_0.3.10-1.diff.gz 10901 RMD160 f15f5fba13f9cd6ec6f872f50d0d493aa92ff045 SHA1 c4017e7d4ca72b3f7264fcc76f3d0aa861344945 SHA256 f7819cfea65991cb4880ce6a92781b47e57057ca21a733c40f3e293957cf08bc
DIST apt-cacher-ng_0.3.10.orig.tar.gz 214000 RMD160 9a8d88617433c005d34e4545f540770fed0de4b8 SHA1 c8d921d9ad6ed7773135843d2b31c57f06eb7ee2 SHA256 3126c41268854234a632eed26b6d10c2788d8cae06f49ce97edc1f1934d2609a
+DIST apt-cacher-ng_0.3.11-1.diff.gz 10965 RMD160 7a9e8ca09f7600bfe0f6d16fab39dca9a3fc7879 SHA1 5731043a1f38c1d8e216e5cdc549d6d579f4d9b1 SHA256 24637e9bfe29fa72bd8a5c57da724ba27c57097d59f46c5e886c78759f47c446
+DIST apt-cacher-ng_0.3.11.orig.tar.gz 214624 RMD160 32760125ebbdde4c91d208a6d6db0644bab0194c SHA1 0cb763318610bfbe129c435d595a846f9824a621 SHA256 e722586ba372b7a49ea192b3362c4f0c5e3534a652e568cc7d3f413978218809
EBUILD apt-cacher-ng-0.3.10.1.ebuild 3232 RMD160 74c6ec3eb314e8ac963a7bead838c067833c46de SHA1 0467cd5a1b37746f969181f1f7e30a750229f24b SHA256 0f6bf5795eb22936e2246d3388a392d9723bceec766e847eb7cd0263e99dd567
-MISC ChangeLog 1075 RMD160 18396c9657e43afc3c5c5adc13dbd744aab8f207 SHA1 c01046c3ed532102419b0e2de0f4b34815816034 SHA256 33789f37efb1b41d29adb9c2dbf3d1f22d0af5ef68cedaecf3f3cc55976c94b2
+EBUILD apt-cacher-ng-0.3.11.1.ebuild 3232 RMD160 74c6ec3eb314e8ac963a7bead838c067833c46de SHA1 0467cd5a1b37746f969181f1f7e30a750229f24b SHA256 0f6bf5795eb22936e2246d3388a392d9723bceec766e847eb7cd0263e99dd567
+MISC ChangeLog 1230 RMD160 d3b11fec92782e864b8176cd31a982b49a53c322 SHA1 f1a5b4f1cd31a83484a0cbe82612b94acdb0dac5 SHA256 d4cee2a4713fba58ff08619a1b3fa4b750c1b2c3514bc86115f6474c9cdf9fc5
MISC metadata.xml 390 RMD160 40659c355f410c97959c1cc60b8aa8e4e00950dd SHA1 176a70493d5c09c2e0e10db57b6f2305ffeeb5e9 SHA256 cfa296bbf435f33a61f87b507401841d70dfdf000623861b534f3d35490a81cf
diff --git a/net-misc/apt-cacher-ng/apt-cacher-ng-0.3.11.1.ebuild b/net-misc/apt-cacher-ng/apt-cacher-ng-0.3.11.1.ebuild
new file mode 100644
index 000000000..b312d1a51
--- /dev/null
+++ b/net-misc/apt-cacher-ng/apt-cacher-ng-0.3.11.1.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+MY_PV=${PV%.*}
+MY_DPV=${PV#*.*.*.}
+
+DESCRIPTION="Yet another implementation of a HTTP proxy for Debian/Ubuntu software packages written in C++"
+HOMEPAGE="http://www.unix-ag.uni-kl.de/~bloch/acng/"
+SRC_URI="mirror://debian/pool/main/a/${PN}/${PN}_${MY_PV}.orig.tar.gz
+ mirror://debian/pool/main/a/${PN}/${PN}_${MY_PV}-${MY_DPV}.diff.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc fuse"
+
+DEPEND="app-arch/bzip2
+ sys-libs/zlib"
+RDEPEND="${DEPEND}
+ dev-lang/perl
+ fuse? ( sys-fs/fuse )"
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+pkg_setup() {
+ # add new user & group for daemon
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 -1 ${PN}
+}
+
+src_unpack() {
+ unpack ${A}
+ epatch "${WORKDIR}/${PN}_${MY_PV}-${MY_DPV}.diff" # Debian patchset number 1.2.3.x
+ cd "${S}" && epatch "${FILESDIR}/${PN}-0.3.8-respect-portage-qa-build-unstripped.patch" # Respect portage
+}
+
+src_compile() {
+ local build="acng"
+ use fuse && build="${build} acngfs"
+ emake CURDIR="${S}" ${build} || die "make '${build}' failed!"
+}
+
+src_install() {
+ # There is no any install target :(
+ # So we do all stuff here
+
+ dosbin apt-cacher-ng || die "Can't install apt-cacher-ng"
+ if use fuse; then dobin acngfs || die "Can't install acngfs"; fi
+
+ newinitd "${FILESDIR}"/initd ${PN} || die "Can't add new init.d ${PN}"
+ newconfd "${FILESDIR}"/confd ${PN} || die "Can't add new conf.d ${PN}"
+
+ # for logrotate
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/logrotate ${PN} || die "Can't install new file ${PN} into '/etc/logrotate.d'"
+
+ doman doc/man/${PN}* || die "Can't install mans"
+ if use fuse; then doman doc/man/acngfs* || die "Can't install man pages for fusefs"; fi
+
+ # Documentation
+ dodoc README TODO VERSION INSTALL ChangeLog || die "Can't install common docs"
+ if use doc; then
+ dodoc doc/*.pdf || die "Can't install docs"
+ dohtml doc/html/* || die "Can't install html docs"
+ docinto examples/conf
+ dodoc conf/* || die "Can't install config examples"
+ fi
+
+ # perl daily cron script
+ dosbin expire-caller.pl || die "Can't install cache cleaner perl script"
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}"/cron.daily ${PN} || die "Can't install new daily cron script"
+
+ # default configuration
+ insinto /etc/${PN}
+ newins conf/acng.conf ${PN}.conf || die "Can't install ${PN} configuration file"
+ newins conf/report.html acng-report.html || die "Can't install ${PN} report page"
+
+ # Some directories must exists
+ keepdir /var/log/${PN}
+ keepdir /var/run/${PN}
+ fowners ${PN}:${PN} \
+ /etc/${PN} \
+ /etc/${PN}/${PN}.conf \
+ /etc/${PN}/acng-report.html \
+ /var/log/${PN} \
+ /var/run/${PN} || die "Can't change owners"
+}
+
+pkg_postinst() {
+ elog "Do not forget about edit configuration file and read manuals!"
+ elog " Default file : /etc/${PN}/${PN}.conf"
+ elog " Manual page : man 8 apt-cache-ng"
+ elog " Documentation: /usr/share/doc/${PF}"
+ if use fuse; then
+ elog "You have choose to build fuse httpfs named 'acngfs'."
+ elog "It's can be used to mount apt cache on server to client"
+ elog "filesystem."
+ elog " Manual page : man 8 acngfs"
+ fi
+ elog "Please note: this ebuild installs /etc/cron.daily/${PN} cron job."
+}