summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-misc/ised/ChangeLog8
-rw-r--r--sci-misc/ised/Manifest4
-rw-r--r--sci-misc/ised/ised-2.1.0.ebuild27
-rw-r--r--sci-misc/ised/metadata.xml8
4 files changed, 47 insertions, 0 deletions
diff --git a/sci-misc/ised/ChangeLog b/sci-misc/ised/ChangeLog
new file mode 100644
index 000000000..e260659d8
--- /dev/null
+++ b/sci-misc/ised/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for sci-misc/ised
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 26 Oct 2009; Jure Varlec (exzombie) <jure.varlec@gmail.com>
+ +ised-2.1.0.ebuild, +metadata.xml:
+ New Ebuild for bug #290615. Thanks to Tommy[D], bonsaikitten and the_mgt
+
diff --git a/sci-misc/ised/Manifest b/sci-misc/ised/Manifest
new file mode 100644
index 000000000..617514a6e
--- /dev/null
+++ b/sci-misc/ised/Manifest
@@ -0,0 +1,4 @@
+DIST ised-2.1.0.tar.bz2 95229 RMD160 d35dddfbc8f6d5172fd410b51781d8549b1e8949 SHA1 609937955a0e2b03623fe80bebb279da858ffcfd SHA256 2d6713d1a637b2f598f588d1fda60b1a7875bcd5717d93fd8d61468cea946809
+EBUILD ised-2.1.0.ebuild 671 RMD160 7ba281e71daf30894a066762d88b8842648b1dee SHA1 b2e10598aec8ef344661113083cad03923df88d2 SHA256 4522eaecacc4331edc636b562420829eb31fc2b6087aaa6a2569e12b1ad56399
+MISC ChangeLog 289 RMD160 5161f9459a56fdaaee877315658b4180fc7afb81 SHA1 37abb0091806d8b579d3951230e9efa617b80f8a SHA256 f06b422f9b4c85e0e3e400e1e7e2cb813c52e06e31abdbf027f9f50d04a772c3
+MISC metadata.xml 299 RMD160 6b648b41d5216ad48c444e58b7fa81f4cca265f7 SHA1 7774810083801dae0c8549cc61d6576352cbb3b7 SHA256 a5a2bfae8ca41d0c3fa5a0470bab44668a6fb889400970224f8c9140e598b505
diff --git a/sci-misc/ised/ised-2.1.0.ebuild b/sci-misc/ised/ised-2.1.0.ebuild
new file mode 100644
index 000000000..701f89df4
--- /dev/null
+++ b/sci-misc/ised/ised-2.1.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+DESCRIPTION="A tool for generating sequences and arithmetic evaluation of stream data."
+HOMEPAGE="http://ised.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="long-types"
+
+DEPEND="sys-libs/readline"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ use long-types && local type_conf="INT_TYPE=LONG FLOAT_TYPE=LONG"
+ econf --with-readline ${type_conf}
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die 'install failed'
+ dodoc AUTHORS ChangeLog NEWS README || die 'dodoc failed'
+}
diff --git a/sci-misc/ised/metadata.xml b/sci-misc/ised/metadata.xml
new file mode 100644
index 000000000..20ecb4e54
--- /dev/null
+++ b/sci-misc/ised/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>maintainer-wanted</herd>
+ <use>
+ <flag name='long-types'>Use 'long long' and 'long double' instead of 'int' and 'double' data types</flag>
+ </use>
+</pkgmetadata>