summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/path/ChangeLog7
-rw-r--r--dev-python/path/Manifest4
-rw-r--r--dev-python/path/path-2.2.ebuild22
3 files changed, 22 insertions, 11 deletions
diff --git a/dev-python/path/ChangeLog b/dev-python/path/ChangeLog
index 96598de89..e90c8dcdf 100644
--- a/dev-python/path/ChangeLog
+++ b/dev-python/path/ChangeLog
@@ -1,7 +1,12 @@
# ChangeLog for dev-python/path
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 03 Jul 2010; Michał Górny (sedzimir) <mgorny.3ehbo@mailnull.com>
+ path-2.2.ebuild:
+ Support for Python ABIs, replaced HOMEPAGE & SRC_URI with pypi ones as the
+ original ones are no longer reachable.
+
16 Feb 2008; Tiago Cunha (tcunha) <me@tiagocunha.org> path-2.2.ebuild:
Zap weird character
diff --git a/dev-python/path/Manifest b/dev-python/path/Manifest
index 97d2d0342..bad644d68 100644
--- a/dev-python/path/Manifest
+++ b/dev-python/path/Manifest
@@ -1,4 +1,4 @@
DIST path-2.2.zip 14108 RMD160 dd377198d8a7bd9f326ecd544f081d2ecd90170d SHA1 8c331673a673390aa884e2fc686dfb9727fe55de SHA256 815f518a94f391d0988de0f361e5cd5661f2732a3a4557bc1392d071cf7ac550
-EBUILD path-2.2.ebuild 615 RMD160 7990cec5521b1ce82960aa47e6288840f1332127 SHA1 7779c5a7ac4977e20fd64c8e1f5a06c6669c07db SHA256 4956171b5f1cd63fe144cc09bc29969cf1c8a5b260c81ee45091cef079250558
-MISC ChangeLog 704 RMD160 69d41b6c80aed18938f44d362d53a6e4cdeaee9c SHA1 d04213fb855dc067e998f4e5a684cce6b0700694 SHA256 9f269bb845fcc9e02099d5b9f24c7efd846f72b1af0d1fd9a9ab39d731cc5695
+EBUILD path-2.2.ebuild 684 RMD160 ca96e2abd5ff31e213fb91b1cdff9fa6f52cef90 SHA1 7c7acbe6b1cdaffb7be8c375843acc869bbb7c8a SHA256 6fea4111e54dcf8cd3bc7414bfe52e86c5732a665f9dd754beff371403275941
+MISC ChangeLog 911 RMD160 fed8338152394bd5a70bc4bff902416c16048a6f SHA1 08d95818ea633f6d45b94c5f41a8e2bf22a954d2 SHA256 f1ebe6e2449bde3a9a82c74e6dad6dac6d532c493d5b1448204d6edb8756c3e0
MISC metadata.xml 229 RMD160 f0f6417bec31ce8baba6d476664f7210c8c84c98 SHA1 e5f94f5caadc6f843fc90bb7959570cd503676fd SHA256 3b08fca3c878bdfc4e7639f477dd542d55a4ab5dce39a475e82633071d13eb3f
diff --git a/dev-python/path/path-2.2.ebuild b/dev-python/path/path-2.2.ebuild
index 1846aff52..e2293ac36 100644
--- a/dev-python/path/path-2.2.ebuild
+++ b/dev-python/path/path-2.2.ebuild
@@ -2,11 +2,16 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+EAPI=2
+PYTHON_DEPEND=2
+SUPPORT_PYTHON_ABIS=1
+RESTRICT_PYTHON_ABIS='3.*'
+
inherit distutils
DESCRIPTION="Helpful python wrapper to the os.path module"
-HOMEPAGE="http://www.jorendorff.com/articles/python/path"
-SRC_URI="http://www.jorendorff.com/articles/python/${PN}/${P}.zip"
+HOMEPAGE="http://pypi.python.org/pypi/path.py"
+SRC_URI="http://pypi.python.org/packages/source/p/${PN}.py/${P}.zip"
LICENSE="freedist"
SLOT="0"
@@ -16,16 +21,17 @@ IUSE=""
DEPEND="app-arch/unzip"
RDEPEND=""
-src_test() {
- ${python} test_path.py || die "test failed"
+my_test() {
+ "$(PYTHON)" test_path.py
}
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
# Don't install test_path.py
sed -i \
-e "s/, 'test_path'//" \
setup.py || die "sed failed"
}
+
+src_test() {
+ python_execute_function my_test
+}