summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/tntdb/Manifest4
-rw-r--r--dev-libs/tntdb/tntdb-0.9.1-r1.ebuild32
-rw-r--r--dev-libs/tntdb/tntdb-0.9.4.ebuild52
3 files changed, 54 insertions, 34 deletions
diff --git a/dev-libs/tntdb/Manifest b/dev-libs/tntdb/Manifest
index 9b30b5a23..a1b296ae1 100644
--- a/dev-libs/tntdb/Manifest
+++ b/dev-libs/tntdb/Manifest
@@ -1,4 +1,4 @@
-DIST tntdb-0.9.1.tar.gz 900898 RMD160 80b781a1815fef352346310f8c27e550c1f9c34d SHA1 f8de08b1d74261cc367253fe9d261bd356f5a1ec SHA256 1c70b3553ddadeefafd90bd67480da5b6a6547571471591ae8645946eef523c6
-EBUILD tntdb-0.9.1-r1.ebuild 871 RMD160 01f05775a2eafa47d99b304a2cde3f6cb3b300dd SHA1 fc2b95867b3754eadb8366d4e9637468b3014323 SHA256 3494ed4085c96911fc3d558016f5f3f396d85be66c36d42c5116e62c650cd821
+DIST tntdb-0.9.4.tar.gz 856061 RMD160 573f0a11d59ebdd15201f244f1ff1c573ca1d09f SHA1 b95cd6c0563bca7050ec6d467753625ffa836084 SHA256 253ea7e64d530adde8aa06180f4aea76ae3113c1f7a5c48c9df1b929bfffb829
+EBUILD tntdb-0.9.4.ebuild 1252 RMD160 71e2f459258af273716503be31f2adf51e8f33e2 SHA1 b5e7c0d823e2a1bb6f34e0ecd8f250ca35f9ecf8 SHA256 b496b4b95cab58a1c38c22089a3dba3b576bd7755c1c2da5853b9d58dd0a981d
MISC ChangeLog 620 RMD160 1224226153f8b6c5091584bbd5700c8013af95f6 SHA1 75ef591d1c8d74853c5504023b050e66d9241de9 SHA256 3018a35eac5a2d24d86c5cdc38cb64b22e6b779ee348dca0434ce42487e96505
MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/dev-libs/tntdb/tntdb-0.9.1-r1.ebuild b/dev-libs/tntdb/tntdb-0.9.1-r1.ebuild
deleted file mode 100644
index 845d38a50..000000000
--- a/dev-libs/tntdb/tntdb-0.9.1-r1.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-DESCRIPTION="Tntdb is a c++-class-library for easy and light database-access. Currently postgresql, sqlite3 and mysql are supported."
-HOMEPAGE="http://www.tntnet.org/tntdb.hms"
-SRC_URI="http://www.tntnet.org/download/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE="mysql postgres sqlite"
-
-RDEPEND="mysql? ( virtual/mysql )
- postgres? ( >=dev-db/postgresql-7 )
- sqlite? ( >=dev-db/sqlite-3 )
- >=dev-libs/cxxtools-1.4.3"
-DEPEND="${RDEPEND}"
-
-src_compile() {
- econf ${myconf} \
- $(use_with mysql) \
- $(use_with postgres postgresql) \
- $(use_with sqlite) \
- || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS ChangeLog README NEWS doc/*.pdf
-}
diff --git a/dev-libs/tntdb/tntdb-0.9.4.ebuild b/dev-libs/tntdb/tntdb-0.9.4.ebuild
new file mode 100644
index 000000000..fb5bc6f2b
--- /dev/null
+++ b/dev-libs/tntdb/tntdb-0.9.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit autotools
+
+DESCRIPTION="A c++-class-library for easy and light database-access. Currently postgresql, sqlite3 and mysql are supported."
+HOMEPAGE="http://www.tntnet.org/tntdb.hms"
+SRC_URI="http://www.tntnet.org/download/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc mysql postgres sqlite"
+
+RDEPEND="mysql? ( virtual/mysql )
+ postgres? ( dev-db/libpq )
+ sqlite? ( >=dev-db/sqlite-3 )
+ >=dev-libs/cxxtools-1.4.3"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+# Needed in this version (0.9.4) due to missing install-sh (and maybe others)
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ AT_M4DIR="m4"
+ eautoreconf
+}
+
+src_compile() {
+ local myconf
+ use doc || myconf="--without-doxygen"
+ econf \
+ ${myconf} \
+ $(use_with mysql) \
+ $(use_with postgres postgresql) \
+ $(use_with sqlite) \
+ --docdir=/usr/share/doc/${PF} \
+ --htmldir=/usr/share/doc/${PF}/html \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README NEWS doc/*.pdf
+
+ insinto /usr/share/doc/${PF}/examples
+ doins demo/*.{cpp,h}
+}