summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/blockhosts/BlockHosts-2.0.2.ebuild')
-rw-r--r--app-admin/blockhosts/BlockHosts-2.0.2.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/app-admin/blockhosts/BlockHosts-2.0.2.ebuild b/app-admin/blockhosts/BlockHosts-2.0.2.ebuild
new file mode 100644
index 000000000..9c9daa429
--- /dev/null
+++ b/app-admin/blockhosts/BlockHosts-2.0.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+NEED_PYTHON=2.3
+
+inherit distutils
+
+DESCRIPTION="Blocks abusive IP hosts which probe your services (such as sshd, proftpd)"
+HOMEPAGE="http://www.aczoom.com/cms/blockhosts/"
+SRC_URI="http://www.aczoom.com/tools/blockhosts/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc logrotate"
+
+DEPEND=""
+RDEPEND="logrotate? ( app-admin/logrotate )"
+
+DOCS="CHANGES"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # don't let setup.py install bhrss.py to /usr/bin
+ sed -i \
+ -e "s/,.*bhrss\.py'//" \
+ setup.py || die "sed failed"
+
+ # remove logrotate check if not in IUSE
+ if ! use logrotate; then
+ sed -i \
+ -e "/^if/d" \
+ -e "/DATA_FILES\./d" \
+ setup.py || die "sed failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ insinto /usr/share/${PN}
+ doins bhrss.py
+
+ use doc && dohtml *.html
+}
+
+pkg_postinst() {
+ echo
+ elog "This package isn't configured properly."
+ elog "Please refer to the homepage to do this!"
+ echo
+ elog "bhrss.py cgi script is under /usr/share/${PN}"
+ elog "If you want to use it, put it in your cgi-bin"
+ elog "emerge dev-python/pyxml and copy blockhosts.py"
+ elog "into your python module directory"
+ echo
+}