summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/blockhosts')
-rw-r--r--app-admin/blockhosts/BlockHosts-2.0.2.ebuild60
-rw-r--r--app-admin/blockhosts/ChangeLog17
-rw-r--r--app-admin/blockhosts/Manifest4
-rw-r--r--app-admin/blockhosts/files/digest-BlockHosts-2.0.23
-rw-r--r--app-admin/blockhosts/metadata.xml5
5 files changed, 89 insertions, 0 deletions
diff --git a/app-admin/blockhosts/BlockHosts-2.0.2.ebuild b/app-admin/blockhosts/BlockHosts-2.0.2.ebuild
new file mode 100644
index 000000000..9c9daa429
--- /dev/null
+++ b/app-admin/blockhosts/BlockHosts-2.0.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+NEED_PYTHON=2.3
+
+inherit distutils
+
+DESCRIPTION="Blocks abusive IP hosts which probe your services (such as sshd, proftpd)"
+HOMEPAGE="http://www.aczoom.com/cms/blockhosts/"
+SRC_URI="http://www.aczoom.com/tools/blockhosts/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc logrotate"
+
+DEPEND=""
+RDEPEND="logrotate? ( app-admin/logrotate )"
+
+DOCS="CHANGES"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # don't let setup.py install bhrss.py to /usr/bin
+ sed -i \
+ -e "s/,.*bhrss\.py'//" \
+ setup.py || die "sed failed"
+
+ # remove logrotate check if not in IUSE
+ if ! use logrotate; then
+ sed -i \
+ -e "/^if/d" \
+ -e "/DATA_FILES\./d" \
+ setup.py || die "sed failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ insinto /usr/share/${PN}
+ doins bhrss.py
+
+ use doc && dohtml *.html
+}
+
+pkg_postinst() {
+ echo
+ elog "This package isn't configured properly."
+ elog "Please refer to the homepage to do this!"
+ echo
+ elog "bhrss.py cgi script is under /usr/share/${PN}"
+ elog "If you want to use it, put it in your cgi-bin"
+ elog "emerge dev-python/pyxml and copy blockhosts.py"
+ elog "into your python module directory"
+ echo
+}
diff --git a/app-admin/blockhosts/ChangeLog b/app-admin/blockhosts/ChangeLog
new file mode 100644
index 000000000..c0fad3d81
--- /dev/null
+++ b/app-admin/blockhosts/ChangeLog
@@ -0,0 +1,17 @@
+# ChangeLog for app-admin/BlockHosts
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 09 Apr 2007; Ali Polatel (hawking) <polatel@gmail.com>
+ BlockHosts-2.0.2.ebuild:
+ removed redundant insinto
+
+ 08 Apr 2007; Ali Polatel (hawking) <polatel@gmail.com>
+ BlockHosts-2.0.2.ebuild:
+ use distutils,added logrotate use flag,install bhrss.py to
+ /usr/share/BlockHosts
+
+ 08 Apr 2007; Kevin Funk <krf@gmx.de> +BlockHosts-2.0.2.ebuild,
+ +metadata.xml:
+ Initial ebuild for bug #173631. Thanks to genstef for support.
+
diff --git a/app-admin/blockhosts/Manifest b/app-admin/blockhosts/Manifest
new file mode 100644
index 000000000..407457415
--- /dev/null
+++ b/app-admin/blockhosts/Manifest
@@ -0,0 +1,4 @@
+DIST BlockHosts-2.0.2.tar.gz 37603 RMD160 a24ece582925704cf58945cfe32ffdb00f17efb3 SHA1 6c5d78e3b6f6dd9ae62ad1c1712ea7ce4e557cd9 SHA256 fdcabc7520a22fa4e05888cfadf7c1a7a7618bba2e38122476a6f7c02cec5573
+EBUILD BlockHosts-2.0.2.ebuild 1271 RMD160 9824307820f10d4d0559cb531e0cdd322dda4201 SHA1 b420d2dbb64a16fb755f0bd391d0f8deca98e401 SHA256 b3da21debd6df1921dd92f8cde932c59c2119cf6fbdd16bbc4f8d358d5db9a4c
+MISC ChangeLog 552 RMD160 09784e3718793eab1579a7f009d5ef3b1770d1c0 SHA1 d0013ca228aafd0b8d7b210079eae548d275b371 SHA256 438a755eeeacafe2e62541a31edc2523f63993b1e23f5ed1dda892b90b61ac3a
+MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/app-admin/blockhosts/files/digest-BlockHosts-2.0.2 b/app-admin/blockhosts/files/digest-BlockHosts-2.0.2
new file mode 100644
index 000000000..097c149a6
--- /dev/null
+++ b/app-admin/blockhosts/files/digest-BlockHosts-2.0.2
@@ -0,0 +1,3 @@
+MD5 5d43dea9224da803580eaa45f43fb317 BlockHosts-2.0.2.tar.gz 37603
+RMD160 a24ece582925704cf58945cfe32ffdb00f17efb3 BlockHosts-2.0.2.tar.gz 37603
+SHA256 fdcabc7520a22fa4e05888cfadf7c1a7a7618bba2e38122476a6f7c02cec5573 BlockHosts-2.0.2.tar.gz 37603
diff --git a/app-admin/blockhosts/metadata.xml b/app-admin/blockhosts/metadata.xml
new file mode 100644
index 000000000..7e3286984
--- /dev/null
+++ b/app-admin/blockhosts/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>maintainer-wanted</herd>
+</pkgmetadata>