summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-antivirus/kav4fileservers/kav4fileservers-5.5.3.ebuild')
-rw-r--r--app-antivirus/kav4fileservers/kav4fileservers-5.5.3.ebuild90
1 files changed, 90 insertions, 0 deletions
diff --git a/app-antivirus/kav4fileservers/kav4fileservers-5.5.3.ebuild b/app-antivirus/kav4fileservers/kav4fileservers-5.5.3.ebuild
new file mode 100644
index 000000000..f373c9a0d
--- /dev/null
+++ b/app-antivirus/kav4fileservers/kav4fileservers-5.5.3.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+MY_P="kav4fileservers-linux-${PV}"
+S="${WORKDIR}/kav4fileservers-linux-install"
+
+DESCRIPTION="Kaspersky File Server virus scanner"
+HOMEPAGE="http://www.kaspersky.com/"
+SRC_URI="ftp://ftp.kaspersky.com/products/release/english/businessoptimal/file_servers/kavlinuxserver/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="KASPERSKY"
+KEYWORDS="-* ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="virtual/cron"
+PROVIDE="virtual/antivirus"
+RESTRICT="mirror strip"
+
+pkg_setup() {
+ enewgroup klusers
+ enewuser kluser -1 -1 /var/db/kav klusers
+}
+
+src_compile() {
+ einfo "Nothing to compile, installing Kasperky AV for Fileservers..."
+}
+
+src_install() {
+ dodir /var/log/kav/5.5/kav4unix
+ dodir /var/db/kav/5.5/kav4unix/{bases,bases.backup,licenses,patches}
+ fowners kluser:klusers /var/log/kav/5.5/kav4unix
+ fowners kluser:klusers /var/db/kav/5.5/kav4unix/licenses
+ fperms 0770 /var/log/kav/5.5/kav4unix
+ fperms 0770 /var/db/kav/5.5/kav4unix/licenses
+
+ insinto /var/db/kav/5.5/kav4unix/bases
+ doins bases/*
+
+ into /opt/kav/5.5/kav4unix
+ dobin bin/*
+
+ insinto /opt/kav/5.5/kav4unix/contrib
+ insopts -m0755
+ doins contrib/*.sh
+ insopts -m0644
+ doins contrib/*.wbm
+
+ insinto /etc/kav/5.5/kav4unix
+ doins kav4unix/kav4unix.conf
+
+ # TODO: provide a gentooified initscript
+ doinitd ${S}/init.d/kavmonitor
+
+ dodoc kav4unix/ChangeLog
+ doman man8/*.8
+}
+
+pkg_postinst() {
+ ewarn "IMPORTANT!!! You must install a valid Kaspersky Lab license file"
+ ewarn "to use the application. Licenses should be installed into"
+ ewarn "/var/db/kav/5.5/kav4unix/licenses. To do this, run:"
+ ewarn
+ ewarn " /opt/kav/5.5/kav4unix/bin/licensemanager -a <keyfile> "
+ ewarn
+ ewarn "You need to download the latest anti-virus bases before using"
+ ewarn "this application. To do this, run:"
+ ewarn
+ ewarn " /opt/kav/5.5/kav4unix/bin/keepup2date"
+
+ einfo
+ einfo " To keep anti-virus bases up-to-date, create a cron job for KAV:"
+ einfo
+ einfo " crontab -u kluser -e"
+ einfo
+ einfo " and add the following line (change the frequency of update if required):"
+ einfo
+ einfo " * */4 * * * /opt/kav/5.5/kav4unix/bin/keepup2date >/dev/null 2>&1"
+ einfo
+ einfo "Configuration file was installed in /etc/kav/5.5/kav4unix/kav4unix.conf."
+ einfo "See \"man 8 kav4unix.conf\" for detailed configuration info."
+ einfo
+ einfo "If you want to use web interface to configure and use Kaspersky Anti-Virus"
+ einfo "emerge app-admin/webmin and then install the module via webmin interface."
+ einfo "Webmin module is located in /opt/kav/5.5/kav4unix/contrib/kavfs.wbm"
+}