summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/zpaq/zpaq-1.09.ebuild')
-rw-r--r--app-arch/zpaq/zpaq-1.09.ebuild18
1 files changed, 14 insertions, 4 deletions
diff --git a/app-arch/zpaq/zpaq-1.09.ebuild b/app-arch/zpaq/zpaq-1.09.ebuild
index 5289cdb84..4b8b484ed 100644
--- a/app-arch/zpaq/zpaq-1.09.ebuild
+++ b/app-arch/zpaq/zpaq-1.09.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-inherit multilib toolchain-funcs
+inherit toolchain-funcs
MY_P="${PN}${PV/./}"
DESCRIPTION="Unified compressor for PAQ algorithms"
@@ -14,21 +14,28 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
src_compile() {
# Upstream doesn't provide any Makefile
# -DOPT is broken (at least) on Linux
"$(tc-getCXX)" ${CXXFLAGS} -DNDEBUG zpaq.cpp -o zpaq || die 'compiling zpaq failed'
- "$(tc-getCXX)" ${CXXFLAGS} lzppre.cpp -o zpaq-lzppre || die 'compiling lzppre failed'
+ "$(tc-getCXX)" ${CXXFLAGS} lzppre.cpp -o lzppre || die 'compiling lzppre failed'
- sed -e 's/lzppre/zpaq-&/' -i *.cfg || die 'sed failed'
+ sed -e 's:^pcomp :&/usr/libexec/zpaq/:' -i *.cfg || die 'sed failed'
}
src_install() {
- dobin zpaq zpaq-lzppre || die 'dobin failed'
+ dobin zpaq || die 'dobin failed'
dodoc readme.txt || die 'dodoc failed'
+ # Preprocessors
+ exeinto /usr/libexec/zpaq
+ doexe lzppre || die 'doexe failed'
+
# These are more like compression profiles, so install them in /usr/share
insinto /usr/share/zpaq
doins *.cfg || die 'doins failed'
@@ -42,4 +49,7 @@ pkg_postinst() {
elog "We install few default configs in /usr/share/zpaq to start with. They can"
elog "be used like that:"
elog " zpaq c/usr/share/zpaq/max.cfg out.zpaq files"
+ elog
+ elog "You may also want to install app-arch/zpaq-extras package which provides"
+ elog "few additional configs and preprocessors for use with zpaq."
}