summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup/darbackup/darbackup-0.7.27.ebuild')
-rw-r--r--app-backup/darbackup/darbackup-0.7.27.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-backup/darbackup/darbackup-0.7.27.ebuild b/app-backup/darbackup/darbackup-0.7.27.ebuild
new file mode 100644
index 000000000..893cfed9e
--- /dev/null
+++ b/app-backup/darbackup/darbackup-0.7.27.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils subversion
+
+ESVN_REPO_URI="https://faracvs.cs.uni-magdeburg.de/svn/christsc/${PN}/${PN}/branches/${PV}"
+
+DESCRIPTION="a wrapper script for creating backups using dar"
+HOMEPAGE="https://faracvs.cs.uni-magdeburg.de/projects/christsc-darbackup/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=app-backup/dar-2.2.6
+ || ( dev-util/bdelta dev-util/xdelta )
+ net-misc/openssh"
+
+pkg_setup() {
+ if ! built_with_use app-backup/dar dar32 && ! built_with_use app-backup/dar dar64; then
+ die 'You must have dar32 or dar64 useflags for app-backup/dar enabled.'
+ fi
+
+ enewgroup backup
+}
+
+src_install() {
+ dobin darbackup
+ doman darbackup.1
+}