summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup/rdup/rdup-0.9.9.ebuild')
-rw-r--r--app-backup/rdup/rdup-0.9.9.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-backup/rdup/rdup-0.9.9.ebuild b/app-backup/rdup/rdup-0.9.9.ebuild
new file mode 100644
index 000000000..84dbad323
--- /dev/null
+++ b/app-backup/rdup/rdup-0.9.9.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="The only backup program that doesn't make backups"
+HOMEPAGE="http://www.miek.nl/projects/rdup"
+SRC_URI="http://www.miek.nl/projects/${PN}/${P}.tar.bz2"
+LICENSE="GPL-3"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="path-encryption test"
+
+RDEPEND="app-arch/libarchive
+ dev-libs/glib
+ dev-libs/libpcre
+ path-encryption? ( dev-libs/nettle )"
+DEPEND="${RDEPEND}
+ test? ( dev-util/dejagnu )"
+
+src_compile() {
+ econf $(use_with path-encryption nettle)
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dosym ../lib/rdup/rdup-simple.sh /usr/bin/rdup-simple || die "dosym failed"
+
+ dodoc AUTHORS ChangeLog DESIGN README || die "dodoc failed"
+}