summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/darbackup/darbackup-0.7-r1.ebuild30
-rw-r--r--app-backup/darbackup/darbackup-0.7.11-svn383.ebuild31
-rw-r--r--app-backup/darbackup/darbackup-0.7.12.ebuild31
-rw-r--r--app-backup/darbackup/darbackup-0.7.13-svn388.ebuild31
-rw-r--r--app-backup/darbackup/darbackup-0.7.13-svn392.ebuild31
-rw-r--r--app-backup/darbackup/darbackup-0.7.13-svn394.ebuild31
-rw-r--r--app-backup/darbackup/darbackup-0.7.13.ebuild31
-rw-r--r--app-backup/darbackup/darbackup-0.7.8.ebuild31
8 files changed, 247 insertions, 0 deletions
diff --git a/app-backup/darbackup/darbackup-0.7-r1.ebuild b/app-backup/darbackup/darbackup-0.7-r1.ebuild
new file mode 100644
index 000000000..b7a6c1844
--- /dev/null
+++ b/app-backup/darbackup/darbackup-0.7-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit subversion
+
+ESVN_REPO_URI="https://faracvs.cs.uni-magdeburg.de/svn/christsc/darbackup/darbackup/branches/0.7-stable"
+
+DESCRIPTION="a wrapper script for creating backups using dar"
+HOMEPAGE="https://faracvs.cs.uni-magdeburg.de/projects/christsc-darbackup/"
+SRC_URI=""
+IUSE=""
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64"
+RDEPEND=">=app-backup/dar-2.2.6
+ || ( dev-util/bdelta dev-util/xdelta )
+ net-misc/openssh"
+DEPEND=">=app-shells/bash-3.0"
+
+src_install() {
+ dobin darbackup
+ doman darbackup.1
+}
+
+pkg_setup() {
+ if ! built_with_use dar dar32 && ! built_with_use dar dar64; then
+ die 'You must have dar32 or dar64 useflags enabled.'
+ fi
+}
diff --git a/app-backup/darbackup/darbackup-0.7.11-svn383.ebuild b/app-backup/darbackup/darbackup-0.7.11-svn383.ebuild
new file mode 100644
index 000000000..cc1e19137
--- /dev/null
+++ b/app-backup/darbackup/darbackup-0.7.11-svn383.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit subversion
+
+ESVN_REPO_URI="https://faracvs.cs.uni-magdeburg.de/svn/christsc/darbackup/darbackup/branches/0.7.11-svn383"
+
+DESCRIPTION="a wrapper script for creating backups using dar"
+HOMEPAGE="https://faracvs.cs.uni-magdeburg.de/projects/christsc-darbackup/"
+SRC_URI=""
+IUSE=""
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64"
+RDEPEND=">=app-backup/dar-2.2.6
+ || ( dev-util/bdelta dev-util/xdelta )
+ net-misc/openssh"
+DEPEND=">=app-shells/bash-3.0"
+
+src_install() {
+ dobin darbackup
+ doman darbackup.1
+}
+
+pkg_setup() {
+ enewgroup backup
+ if ! built_with_use dar dar32 && ! built_with_use dar dar64; then
+ die 'You must have dar32 or dar64 useflags for dar enabled.'
+ fi
+}
diff --git a/app-backup/darbackup/darbackup-0.7.12.ebuild b/app-backup/darbackup/darbackup-0.7.12.ebuild
new file mode 100644
index 000000000..5b46e97f8
--- /dev/null
+++ b/app-backup/darbackup/darbackup-0.7.12.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit subversion
+
+ESVN_REPO_URI="https://faracvs.cs.uni-magdeburg.de/svn/christsc/darbackup/darbackup/branches/0.7.12"
+
+DESCRIPTION="a wrapper script for creating backups using dar"
+HOMEPAGE="https://faracvs.cs.uni-magdeburg.de/projects/christsc-darbackup/"
+SRC_URI=""
+IUSE=""
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64"
+RDEPEND=">=app-backup/dar-2.2.6
+ || ( dev-util/bdelta dev-util/xdelta )
+ net-misc/openssh"
+DEPEND=">=app-shells/bash-3.0"
+
+src_install() {
+ dobin darbackup
+ doman darbackup.1
+}
+
+pkg_setup() {
+ enewgroup backup
+ if ! built_with_use dar dar32 && ! built_with_use dar dar64; then
+ die 'You must have dar32 or dar64 useflags for dar enabled.'
+ fi
+}
diff --git a/app-backup/darbackup/darbackup-0.7.13-svn388.ebuild b/app-backup/darbackup/darbackup-0.7.13-svn388.ebuild
new file mode 100644
index 000000000..4fd5b9850
--- /dev/null
+++ b/app-backup/darbackup/darbackup-0.7.13-svn388.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit subversion
+
+ESVN_REPO_URI="https://faracvs.cs.uni-magdeburg.de/svn/christsc/darbackup/darbackup/branches/0.7.13-svn388"
+
+DESCRIPTION="a wrapper script for creating backups using dar"
+HOMEPAGE="https://faracvs.cs.uni-magdeburg.de/projects/christsc-darbackup/"
+SRC_URI=""
+IUSE=""
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64"
+RDEPEND=">=app-backup/dar-2.2.6
+ || ( dev-util/bdelta dev-util/xdelta )
+ net-misc/openssh"
+DEPEND=">=app-shells/bash-3.0"
+
+src_install() {
+ dobin darbackup
+ doman darbackup.1
+}
+
+pkg_setup() {
+ enewgroup backup
+ if ! built_with_use dar dar32 && ! built_with_use dar dar64; then
+ die 'You must have dar32 or dar64 useflags for dar enabled.'
+ fi
+}
diff --git a/app-backup/darbackup/darbackup-0.7.13-svn392.ebuild b/app-backup/darbackup/darbackup-0.7.13-svn392.ebuild
new file mode 100644
index 000000000..ef93c2c9c
--- /dev/null
+++ b/app-backup/darbackup/darbackup-0.7.13-svn392.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit subversion
+
+ESVN_REPO_URI="https://faracvs.cs.uni-magdeburg.de/svn/christsc/darbackup/darbackup/branches/0.7.13-svn392"
+
+DESCRIPTION="a wrapper script for creating backups using dar"
+HOMEPAGE="https://faracvs.cs.uni-magdeburg.de/projects/christsc-darbackup/"
+SRC_URI=""
+IUSE=""
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64"
+RDEPEND=">=app-backup/dar-2.2.6
+ || ( dev-util/bdelta dev-util/xdelta )
+ net-misc/openssh"
+DEPEND=">=app-shells/bash-3.0"
+
+src_install() {
+ dobin darbackup
+ doman darbackup.1
+}
+
+pkg_setup() {
+ enewgroup backup
+ if ! built_with_use dar dar32 && ! built_with_use dar dar64; then
+ die 'You must have dar32 or dar64 useflags for dar enabled.'
+ fi
+}
diff --git a/app-backup/darbackup/darbackup-0.7.13-svn394.ebuild b/app-backup/darbackup/darbackup-0.7.13-svn394.ebuild
new file mode 100644
index 000000000..bcd40acc9
--- /dev/null
+++ b/app-backup/darbackup/darbackup-0.7.13-svn394.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit subversion
+
+ESVN_REPO_URI="https://faracvs.cs.uni-magdeburg.de/svn/christsc/darbackup/darbackup/branches/0.7.13-svn394"
+
+DESCRIPTION="a wrapper script for creating backups using dar"
+HOMEPAGE="https://faracvs.cs.uni-magdeburg.de/projects/christsc-darbackup/"
+SRC_URI=""
+IUSE=""
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64"
+RDEPEND=">=app-backup/dar-2.2.6
+ || ( dev-util/bdelta dev-util/xdelta )
+ net-misc/openssh"
+DEPEND=">=app-shells/bash-3.0"
+
+src_install() {
+ dobin darbackup
+ doman darbackup.1
+}
+
+pkg_setup() {
+ enewgroup backup
+ if ! built_with_use dar dar32 && ! built_with_use dar dar64; then
+ die 'You must have dar32 or dar64 useflags for dar enabled.'
+ fi
+}
diff --git a/app-backup/darbackup/darbackup-0.7.13.ebuild b/app-backup/darbackup/darbackup-0.7.13.ebuild
new file mode 100644
index 000000000..6663abf68
--- /dev/null
+++ b/app-backup/darbackup/darbackup-0.7.13.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit subversion
+
+ESVN_REPO_URI="https://faracvs.cs.uni-magdeburg.de/svn/christsc/darbackup/darbackup/branches/0.7.13"
+
+DESCRIPTION="a wrapper script for creating backups using dar"
+HOMEPAGE="https://faracvs.cs.uni-magdeburg.de/projects/christsc-darbackup/"
+SRC_URI=""
+IUSE=""
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64"
+RDEPEND=">=app-backup/dar-2.2.6
+ || ( dev-util/bdelta dev-util/xdelta )
+ net-misc/openssh"
+DEPEND=">=app-shells/bash-3.0"
+
+src_install() {
+ dobin darbackup
+ doman darbackup.1
+}
+
+pkg_setup() {
+ enewgroup backup
+ if ! built_with_use dar dar32 && ! built_with_use dar dar64; then
+ die 'You must have dar32 or dar64 useflags for dar enabled.'
+ fi
+}
diff --git a/app-backup/darbackup/darbackup-0.7.8.ebuild b/app-backup/darbackup/darbackup-0.7.8.ebuild
new file mode 100644
index 000000000..2e42d48be
--- /dev/null
+++ b/app-backup/darbackup/darbackup-0.7.8.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit subversion
+
+ESVN_REPO_URI="https://faracvs.cs.uni-magdeburg.de/svn/christsc/darbackup/darbackup/branches/0.7.8"
+
+DESCRIPTION="a wrapper script for creating backups using dar"
+HOMEPAGE="https://faracvs.cs.uni-magdeburg.de/projects/christsc-darbackup/"
+SRC_URI=""
+IUSE=""
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64"
+RDEPEND=">=app-backup/dar-2.2.6
+ || ( dev-util/bdelta dev-util/xdelta )
+ net-misc/openssh"
+DEPEND=">=app-shells/bash-3.0"
+
+src_install() {
+ dobin darbackup
+ doman darbackup.1
+}
+
+pkg_setup() {
+ enewgroup backup
+ if ! built_with_use dar dar32 && ! built_with_use dar dar64; then
+ die 'You must have dar32 or dar64 useflags for dar enabled.'
+ fi
+}