summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/x2/x2-1.1.0.ebuild')
-rw-r--r--app-editors/x2/x2-1.1.0.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/app-editors/x2/x2-1.1.0.ebuild b/app-editors/x2/x2-1.1.0.ebuild
index 742942df5..451009d89 100644
--- a/app-editors/x2/x2-1.1.0.ebuild
+++ b/app-editors/x2/x2-1.1.0.ebuild
@@ -4,7 +4,9 @@
EAPI=4
-DESCRIPTION="a micro-ide/text editor written in C/GTK+"
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A micro-ide/text editor written in C/GTK+"
HOMEPAGE="http://gnomefiles.org/content/show.php/X2?content=145463"
SRC_URI="http://gnomefiles.org/CONTENT/content-files/145463-${P}.tar.gz"
@@ -15,4 +17,11 @@ IUSE=""
RDEPEND="x11-libs/gtksourceview:2.0
x11-libs/vte:0"
-DEPEND="${RDEPEND}"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare(){
+ epatch "${FILESDIR}/${P}-desktop.patch"
+ epatch "${FILESDIR}/${P}-Makefile.patch"
+ tc-export CC
+}