summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/ibus-anthy/ibus-anthy-9999.ebuild')
-rw-r--r--app-i18n/ibus-anthy/ibus-anthy-9999.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/app-i18n/ibus-anthy/ibus-anthy-9999.ebuild b/app-i18n/ibus-anthy/ibus-anthy-9999.ebuild
new file mode 100644
index 000000000..8325b5fa2
--- /dev/null
+++ b/app-i18n/ibus-anthy/ibus-anthy-9999.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="1"
+EGIT_REPO_URI="git://github.com/phuang/ibus-anthy.git"
+
+inherit autotools git
+
+DESCRIPTION="Japanese input method Anthy IMEngine for IBus Framework"
+HOMEPAGE="http://ibus.googlecode.com"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="nls"
+
+# autopoint needs cvs. Bug #152872
+DEPEND="app-i18n/anthy
+ >=dev-lang/python-2.5
+ dev-lang/swig
+ sys-devel/gettext
+ dev-util/cvs"
+RDEPEND="app-i18n/ibus
+ app-i18n/anthy
+ >=dev-lang/python-2.5"
+
+src_unpack() {
+ git_src_unpack
+ autopoint || die "failed to run autopoint"
+ eautoreconf
+}
+
+src_compile() {
+ econf $(use_enable nls) \
+ --enable-maintainer-mode \
+ --disable-option-checking \
+ --disable-rpath
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "Install failed"
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ ewarn "This package is very experimental, please report your bugs to"
+ ewarn "http://ibus.googlecode.com/issues/list"
+ elog "You should run ibus-setup and enable IM Engines you want to use."
+}