summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/ocropus-svn/ocropus-svn-9999.ebuild')
-rw-r--r--app-text/ocropus-svn/ocropus-svn-9999.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-text/ocropus-svn/ocropus-svn-9999.ebuild b/app-text/ocropus-svn/ocropus-svn-9999.ebuild
new file mode 100644
index 000000000..b41ebd546
--- /dev/null
+++ b/app-text/ocropus-svn/ocropus-svn-9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit subversion
+
+DESCRIPTION="OCRopus is a state-of-the-art document analysis and OCR system."
+HOMEPAGE="http://code.google.com/p/ocropus/"
+
+ESVN_REPO_URI="http://ocropus.googlecode.com/svn/trunk"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND=">=app-text/tesseract-1.04b
+ app-text/aspell
+ media-libs/tiff
+ media-libs/libpng
+ media-libs/jpeg"
+DEPEND="${RDEPEND}
+ dev-util/jam"
+
+src_compile() {
+ econf --with-tesseract=/usr
+ emake
+}
+
+src_test() {
+ cd "${S}/testing"
+ ./test-compile
+ ./test-run || die "At least one test failed"
+}
+
+src_install() {
+ dobin ocropus-cmd/ocropus
+ dodoc README DIRS
+}
+
+