summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/ETL/ETL-0.04.09.ebuild')
-rw-r--r--dev-cpp/ETL/ETL-0.04.09.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-cpp/ETL/ETL-0.04.09.ebuild b/dev-cpp/ETL/ETL-0.04.09.ebuild
new file mode 100644
index 000000000..5c5370f25
--- /dev/null
+++ b/dev-cpp/ETL/ETL-0.04.09.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="1.6"
+inherit autotools
+
+DESCRIPTION="VoriaETL is a multiplatform class and template library designed to complement and supplement the C++ STL."
+HOMEPAGE="http://www.synfig.com/"
+SRC_URI="mirror://sourceforge/synfig/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+DEPEND="doc? ( app-doc/doxygen )"
+
+
+src_compile() {
+ ./bootstrap || die 'Bootstrap failed.'
+ econf || die 'Configure failed.'
+ emake || die 'Make failed.'
+ if use doc; then
+ emake docs || die "make docs failed."
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die 'Install failed!'
+ if use doc; then
+ dohtml doc/html/*
+ fi
+}