summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/libthrowable/libthrowable-0.9.5.ebuild')
-rw-r--r--dev-cpp/libthrowable/libthrowable-0.9.5.ebuild9
1 files changed, 9 insertions, 0 deletions
diff --git a/dev-cpp/libthrowable/libthrowable-0.9.5.ebuild b/dev-cpp/libthrowable/libthrowable-0.9.5.ebuild
index baa9a4e6f..6933eb915 100644
--- a/dev-cpp/libthrowable/libthrowable-0.9.5.ebuild
+++ b/dev-cpp/libthrowable/libthrowable-0.9.5.ebuild
@@ -29,6 +29,15 @@ pkg_setup() {
}
+src_unpack() {
+ unpack ${A}
+
+ # make it run on 64bit platforms
+ cd "${S}/libthrowable/internal/"
+ epatch "${FILESDIR}/${P}-internal.cc-64bit.patch"
+ epatch "${FILESDIR}/${P}-internal.h-64bit.patch"
+
+}
src_compile() {
econf $(use_enable threads pthreads) \
|| die "econf failed"