summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/libvmime')
-rw-r--r--dev-cpp/libvmime/ChangeLog6
-rw-r--r--dev-cpp/libvmime/Manifest7
-rw-r--r--dev-cpp/libvmime/files/libvmime-0.9.0-gcc4_4.patch12
-rw-r--r--dev-cpp/libvmime/libvmime-0.9.0.ebuild49
-rw-r--r--dev-cpp/libvmime/metadata.xml5
5 files changed, 53 insertions, 26 deletions
diff --git a/dev-cpp/libvmime/ChangeLog b/dev-cpp/libvmime/ChangeLog
index feff9b89d..509f61db1 100644
--- a/dev-cpp/libvmime/ChangeLog
+++ b/dev-cpp/libvmime/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for dev-cpp/libvmime
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 20 Jun 2009; HĂ„vard Wall <haavardw@ifi.uio.no> libvmime-0.9.0.ebuild,
+ +files/libvmime-0.9.0-gcc4_4.patch, metadata.xml:
+ compile with gcc-4.4, improved dependencies, new USE flags
+
30 Dec 2008; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
-libvmime-0.8.1.ebuild, +libvmime-0.9.0.ebuild:
Version bump as requested and tested in bug 251213
diff --git a/dev-cpp/libvmime/Manifest b/dev-cpp/libvmime/Manifest
index 282db1748..dc3d069e1 100644
--- a/dev-cpp/libvmime/Manifest
+++ b/dev-cpp/libvmime/Manifest
@@ -1,4 +1,5 @@
+AUX libvmime-0.9.0-gcc4_4.patch 351 RMD160 dd8a63aff5763f2b7375e6daaa76094dd36094a3 SHA1 6c0239e34e1790bd030c407385419a4239b82930 SHA256 0e05499ab46d764a2d53e6131f4d5be0dc50bbf6d3eb8c481490ef92f716ca8c
DIST libvmime-0.9.0.tar.bz2 501168 RMD160 220c51f38587d503a9eaff58bc54d20af986b02f SHA1 02215e1d8ea758f486c32e7bff63a04f71a9b736 SHA256 941aa406e7a287e7981ac49f5665663d2d5feed0dd55a5459a311bf806b64363
-EBUILD libvmime-0.9.0.ebuild 1381 RMD160 31153990e36fa83e3c272c830a68ffac3a232cda SHA1 e17c6edfaada2aeb25dcfd9171f1de205e0a6e45 SHA256 3af4bad3e38dc339ce73c0ee3dcf44acf15658762f8a7e897b8c69b3eda1806f
-MISC ChangeLog 1247 RMD160 8fe0c28a9810b83700d8ceb53d99dcfa35fcfa6d SHA1 ad2ad3a33f758884089472e60d4973003e90dc68 SHA256 89cf0e25bc2efefe5b3f357d67f92edb26ee0fdcc656e08dae608a02bc105530
-MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
+EBUILD libvmime-0.9.0.ebuild 1722 RMD160 2c00183b215d963be0fc1474af3e20b27870ec38 SHA1 ee2db50c7f69ff019e8c07fc5c12267fe50cabb0 SHA256 8bebcfd2efd2ac29f265e02d40b83c1352d091fb30683a96f385600191faa81f
+MISC ChangeLog 1434 RMD160 7a4deb4126421b12c72f04a030981001142fb638 SHA1 7018a08e299bdc1c038a7d295bceff6b5152ddec SHA256 a2b7df43ef68c5c042c0638fc320b253f0367fb350e6405e64f8c01ca4b46973
+MISC metadata.xml 402 RMD160 917bbe540ac49bef7417f612373861866d947f7b SHA1 94477c84465834ceff5286f4c0c53ee54e390bb3 SHA256 3ff4d8c8f42c03ec0d62522b4be18312d30951e88c404ab82f1ca35909e7463c
diff --git a/dev-cpp/libvmime/files/libvmime-0.9.0-gcc4_4.patch b/dev-cpp/libvmime/files/libvmime-0.9.0-gcc4_4.patch
new file mode 100644
index 000000000..7db944be2
--- /dev/null
+++ b/dev-cpp/libvmime/files/libvmime-0.9.0-gcc4_4.patch
@@ -0,0 +1,12 @@
+Index: vmime/src/platforms/posix/posixFile.cpp
+===================================================================
+--- vmime/src/platforms/posix/posixFile.cpp (revision 482)
++++ vmime/src/platforms/posix/posixFile.cpp (revision 483)
+@@ -32,6 +32,7 @@
+
+ #include <dirent.h>
+
++#include <stdio.h>
+ #include <string.h>
+
+ #include "vmime/exception.hpp"
diff --git a/dev-cpp/libvmime/libvmime-0.9.0.ebuild b/dev-cpp/libvmime/libvmime-0.9.0.ebuild
index 3b6bba2af..5a075cb5f 100644
--- a/dev-cpp/libvmime/libvmime-0.9.0.ebuild
+++ b/dev-cpp/libvmime/libvmime-0.9.0.ebuild
@@ -1,46 +1,48 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+EAPI="1"
inherit eutils
-DESCRIPTION="A powerful C++ class library for working with MIME messages and services like IMAP, POP or SMTP."
-HOMEPAGE="http://www.vmime.org/"
+DESCRIPTION="Library for working with MIME messages and Internet messaging services like IMAP, POP or SMTP"
+HOMEPAGE="http://www.vmime.org"
SRC_URI="mirror://sourceforge/vmime/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="debug doc examples sasl ssl"
+IUSE="debug doc examples +imap +maildir +pop sasl sendmail +smtp ssl"
-RDEPEND="sasl? ( net-libs/libgsasl )
- ssl? ( net-libs/gnutls )
- virtual/libiconv"
+RDEPEND="virtual/libiconv
+ ssl? ( >=net-libs/gnutls-1.2.0 )
+ sasl? ( || ( net-libs/libgsasl net-misc/gsasl ) )
+ sendmail? ( || ( mail-mta/ssmtp mail-mta/sendmail ) )"
DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )"
+ doc? ( app-doc/doxygen )"
src_unpack() {
unpack ${A}
cd "${S}"
+
sed -i \
-e "s|doc/\${PACKAGE_TARNAME}|doc/${PF}|" \
-e "s|doc/\$(GENERIC_LIBRARY_NAME)|doc/${PF}|" \
configure Makefile.in || die "sed failed"
+
+ epatch "${FILESDIR}/${P}-gcc4_4.patch"
}
src_compile() {
- econf \
- $(use_enable debug) \
- $(use_enable sasl) \
- $(use_enable ssl tls) \
- --enable-platform-posix \
- --enable-messaging \
- --enable-messaging-proto-pop3 \
- --enable-messaging-proto-smtp \
- --enable-messaging-proto-imap \
- --enable-messaging-proto-maildir \
- --enable-messaging-proto-sendmail \
- || die "econf failed"
+ econf $(use_enable debug) \
+ $(use_enable sasl) \
+ $(use_enable ssl tls) \
+ $(use_enable pop messaging-proto-pop3) \
+ $(use_enable smtp messaging-proto-smtp) \
+ $(use_enable imap messaging-proto-imap) \
+ $(use_enable maildir messaging-proto-maildir) \
+ $(use_enable sendmail messaging-proto-sendmail)
+
emake || die "emake failed"
if use doc ; then
doxygen vmime.doxygen || die "doxygen failed"
@@ -49,10 +51,13 @@ src_compile() {
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog || die "dodoc failed"
if use doc ; then
- dohtml doc/html/*
+ dohtml doc/html/* || die "dohtml failed"
fi
insinto /usr/share/doc/${PF}
- use examples && doins -r examples
+ if use examples ; then
+ doins -r examples || die "doins examples failed"
+ fi
}
diff --git a/dev-cpp/libvmime/metadata.xml b/dev-cpp/libvmime/metadata.xml
index 7e3286984..a0845d8e3 100644
--- a/dev-cpp/libvmime/metadata.xml
+++ b/dev-cpp/libvmime/metadata.xml
@@ -2,4 +2,9 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>maintainer-wanted</herd>
+<use>
+ <flag name="pop">Support POP for mail retrieval</flag>
+ <flag name="sendmail">Support for <pkg>mail-mta/sendmail</pkg> as a mail transport agent</flag>
+ <flag name="smtp">Enable support for the SMTP protocol</flag>
+</use>
</pkgmetadata>