summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/pgbouncer/pgbouncer-1.3.2.ebuild')
-rw-r--r--dev-db/pgbouncer/pgbouncer-1.3.2.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/dev-db/pgbouncer/pgbouncer-1.3.2.ebuild b/dev-db/pgbouncer/pgbouncer-1.3.2.ebuild
index 7c3ac4fcc..f9224ab33 100644
--- a/dev-db/pgbouncer/pgbouncer-1.3.2.ebuild
+++ b/dev-db/pgbouncer/pgbouncer-1.3.2.ebuild
@@ -32,20 +32,23 @@ src_prepare() {
src_configure() {
econf \
$(use_enable debug) \
- $(use_enable debug cassert)
+ $(use_enable debug cassert) \
+ --docdir=/usr/share/doc/${PF}
}
src_install() {
emake DESTDIR="${D}" install || die "Install failed"
insinto /etc
- newins "${S}"/etc/pgbouncer.ini pgbouncer.conf || die "Install failed"
+ newins etc/pgbouncer.ini pgbouncer.conf || die "Install failed"
newinitd "${FILESDIR}"/pgbouncer.initd "${PN}" || die "Install failed"
dodoc README NEWS AUTHORS || die "Install failed"
- use doc && dodoc doc/*.txt || die "Install failed"
+ if use doc ; then
+ dodoc doc/*.txt || die "Install failed"
+ fi
- keepdir /var/{run,log}/pgbouncer/
+ dodir /var/{run,log}/pgbouncer/
fperms 0700 /var/{run,log}/pgbouncer/
fowners pgbouncer:pgbouncer /var/{run,log}/pgbouncer/
}