summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/wxSQLite3/wxSQLite3-1.6.0.ebuild')
-rw-r--r--dev-db/wxSQLite3/wxSQLite3-1.6.0.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-db/wxSQLite3/wxSQLite3-1.6.0.ebuild b/dev-db/wxSQLite3/wxSQLite3-1.6.0.ebuild
new file mode 100644
index 000000000..d0e71591d
--- /dev/null
+++ b/dev-db/wxSQLite3/wxSQLite3-1.6.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils wxwidgets
+
+DESCRIPTION="a C++ wrapper around the public domain SQLite 3.x database"
+HOMEPAGE="http://wxcode.sourceforge.net/components/wxsqlite3/"
+SRC_URI="mirror://sourceforge/wxcode/wxsqlite3-${PV}.tar.gz"
+
+LICENSE="wxWinLL-3"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="unicode"
+
+DEPEND=">=x11-libs/wxGTK-2.6
+ =dev-db/sqlite-3*"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/wxsqlite3"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-makefile_in.patch"
+}
+
+src_compile() {
+ export WX_GTK_VER=2.6
+ if use unicode; then
+ need-wxwidgets unicode || die
+ else
+ need-wxwidgets gtk2 || die
+ fi
+
+ econf \
+ $(use_enable unicode) \
+ --enable-shared \
+ --with-gtk \
+ --with-wxshared \
+ --with-sqlite3-prefix=/usr \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc Readme.txt
+ dohtml -r docs/html/*
+ docinto samples
+ dodoc -r samples/*
+}