summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/spatialite/ChangeLog9
-rw-r--r--dev-db/spatialite/Manifest5
-rw-r--r--dev-db/spatialite/metadata.xml12
-rw-r--r--dev-db/spatialite/spatialite-2.3.1.ebuild42
4 files changed, 68 insertions, 0 deletions
diff --git a/dev-db/spatialite/ChangeLog b/dev-db/spatialite/ChangeLog
new file mode 100644
index 000000000..bd662edbe
--- /dev/null
+++ b/dev-db/spatialite/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-db/spatialite
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 20 Aug 2010; Johan Bergström (jbergstroem) <bugs@bergstroem.nu>
+ +spatialite-2.3.1.ebuild, +metadata.xml:
+ New ebuild for bug 284476. Thanks to Tommy[D], neurogeek and xarthisius for
+ feedback
+
diff --git a/dev-db/spatialite/Manifest b/dev-db/spatialite/Manifest
new file mode 100644
index 000000000..6b95e7db3
--- /dev/null
+++ b/dev-db/spatialite/Manifest
@@ -0,0 +1,5 @@
+DIST libspatialite-amalgamation-2.3.1.tar.gz 1552985 RMD160 64f8ea11f30a66c5f9eb304308bc01dca75b646a SHA1 7582979576c12be1952aa85334b1d0a143485a12 SHA256 807d6f4f3e9b65bc871423846aa94225c3a3695defd0c185fbbd0899079a8655
+DIST sql_extensions.html 74273 RMD160 57a0120b4fb24d429d6e678980dac31ca5d9f7c5 SHA1 8f374b66ad5b9e1961ca2858cb16e32dad7ba80b SHA256 133fef13df6b8668d88c59337b63cc1ccdef586ae2235647a39719ec81c45409
+EBUILD spatialite-2.3.1.ebuild 966 RMD160 d087e2f2a1c598b57eb41cab8e63f2d66029bb9c SHA1 0de72d30f152226a824942555b04fe653e60ad13 SHA256 63fde281cc25e8ac2c14a7886b7aa910b561dbb9355777fbf4057bf2852bca9f
+MISC ChangeLog 318 RMD160 37344a5631e3ca75e1fa66663f884e4a8cc3e92a SHA1 024a103e2a01058f9998e876f372615b8e668eaf SHA256 762dc28ef0e0f57a8dcb6ed174a1d611fc7956e52d619d14a3824b86777527ef
+MISC metadata.xml 440 RMD160 6754fce4cc68041e13626409ecef7eb4d2ef9e5d SHA1 702569f0227b9758099b8e20464bb6bbe0fd17e0 SHA256 d3c70f2f21ad187495aa137641149c740eecacd7eeab80cc4fbc5627218fd66f
diff --git a/dev-db/spatialite/metadata.xml b/dev-db/spatialite/metadata.xml
new file mode 100644
index 000000000..67d698cc8
--- /dev/null
+++ b/dev-db/spatialite/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer><email>maintainer-wanted@gentoo.org</email></maintainer>
+<use>
+ <flag name='geos'>Add the <pkg>sci-libs/geos</pkg> library for exact
+ topological tests</flag>
+ <flag name='proj'>Add the <pkg>sci-libs/proj</pkg> library for reprojection
+ features</flag>
+</use>
+</pkgmetadata>
diff --git a/dev-db/spatialite/spatialite-2.3.1.ebuild b/dev-db/spatialite/spatialite-2.3.1.ebuild
new file mode 100644
index 000000000..1420edeb5
--- /dev/null
+++ b/dev-db/spatialite/spatialite-2.3.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header $
+
+EAPI="3"
+
+inherit multilib
+
+MY_P="lib${PN}-amalgamation-${PV}"
+
+DESCRIPTION="A complete Spatial DBMS in a nutshell built upon sqlite"
+HOMEPAGE="http://www.gaia-gis.it/spatialite"
+SRC_URI="http://www.gaia-gis.it/spatialite/${MY_P}.tar.gz
+ doc? ( http://www.gaia-gis.it/${PN}/${PN}-sql-${PV}.html -> sql_extensions.html )"
+
+LICENSE="MPL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc geos proj static-libs"
+
+RDEPEND="dev-db/sqlite:3[extensions]
+ geos? ( sci-libs/geos )
+ proj? ( sci-libs/proj )"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ econf \
+ $(use_enable geos) --with-geos-lib=/usr/$(get_libdir) \
+ $(use_enable proj) --with-proj-lib=/usr/$(get_libdir) \
+ $(use_enable static-libs static)
+
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ if use doc; then
+ dohtml "${DISTDIR}"/sql_extensions.html || die
+ fi
+}