summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/syx/syx-0.1.7.ebuild')
-rw-r--r--dev-lang/syx/syx-0.1.7.ebuild19
1 files changed, 7 insertions, 12 deletions
diff --git a/dev-lang/syx/syx-0.1.7.ebuild b/dev-lang/syx/syx-0.1.7.ebuild
index a13e571a0..faf8bd92b 100644
--- a/dev-lang/syx/syx-0.1.7.ebuild
+++ b/dev-lang/syx/syx-0.1.7.ebuild
@@ -1,9 +1,11 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-DESCRIPTION="Open source implementation of the Smalltalk-80 programming language."
-HOMEPAGE="http://syx.googlecode.com"
+EAPI="4"
+
+DESCRIPTION="Open source implementation of the Smalltalk-80 programming language"
+HOMEPAGE="http://syx.googlecode.com/"
SRC_URI="http://syx.googlecode.com/files/${P}.tar.gz"
LICENSE="MIT"
@@ -13,11 +15,11 @@ IUSE="gmp readline gtk X debug profile"
RDEPEND="gmp? ( dev-libs/gmp )
readline? ( sys-libs/readline )
- gtk? ( >=x11-libs/gtk+-2.12 )
+ gtk? ( x11-libs/gtk+:2 )
X? ( x11-libs/libX11 )"
DEPEND="${RDEPEND}"
-src_compile() {
+src_configure() {
local myconf=
use debug && myconf='--enable-debug=info'
@@ -28,11 +30,4 @@ src_compile() {
$(use_enable profile) \
$(use_with gmp) \
${myconf}
-
- emake || die "Compile failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "Install failed"
- dodoc README ChangeLog TODO || die
}