summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/lua-gd/lua-gd-2.0.33.2.ebuild')
-rw-r--r--dev-libs/lua-gd/lua-gd-2.0.33.2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-libs/lua-gd/lua-gd-2.0.33.2.ebuild b/dev-libs/lua-gd/lua-gd-2.0.33.2.ebuild
new file mode 100644
index 000000000..e5a1361aa
--- /dev/null
+++ b/dev-libs/lua-gd/lua-gd-2.0.33.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit eutils toolchain-funcs versionator
+
+MY_P=${PN}-$(replace_version_separator 3 'r' )
+
+DESCRIPTION="Lua bindings to Thomas Boutell's gd library"
+HOMEPAGE="http://lua-gd.luaforge.net/"
+SRC_URI="http://luaforge.net/frs/download.php/1592/${MY_P}.tar.gz
+ mirror://sourceforge/${PN}/${PN}/${MY_P}%20%28for%20Lua%205.1%29/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND="dev-lang/lua
+ media-libs/gd"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-makefile.patch"
+}
+
+src_compile() {
+ emake LUAPKG=lua CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ emake install LUAPKG=lua DESTDIR="${D}" || die "Install failed"
+ dodoc README || die
+
+ if use doc; then
+ dohtml doc/* || die
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r demos || die
+ fi
+}