summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pycallgraph/pycallgraph-0.5.1.ebuild')
-rw-r--r--dev-python/pycallgraph/pycallgraph-0.5.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pycallgraph/pycallgraph-0.5.1.ebuild b/dev-python/pycallgraph/pycallgraph-0.5.1.ebuild
new file mode 100644
index 000000000..48b3ded11
--- /dev/null
+++ b/dev-python/pycallgraph/pycallgraph-0.5.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="Python library that creates call graphs for Python programs"
+HOMEPAGE="http://pycallgraph.slowchop.com/"
+SRC_URI="http://${PN}.slowchop.com/files/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="media-gfx/graphviz"
+
+RESTRICT_PYTHON_ABIS="3*"
+
+src_install() {
+ distutils_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples/* || die "Install failed"
+ fi
+}