summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pysvn')
-rw-r--r--dev-python/pysvn/ChangeLog6
-rw-r--r--dev-python/pysvn/Manifest6
-rw-r--r--dev-python/pysvn/pysvn-1.6.3.ebuild (renamed from dev-python/pysvn/pysvn-1.6.2.ebuild)11
3 files changed, 18 insertions, 5 deletions
diff --git a/dev-python/pysvn/ChangeLog b/dev-python/pysvn/ChangeLog
index c25959329..9dec892a6 100644
--- a/dev-python/pysvn/ChangeLog
+++ b/dev-python/pysvn/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for dev-python/pysvn
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 12 Feb 2009; Markus Rennings (mren) <mren@mrmx.de> -pysvn-1.6.2.ebuild,
+ +pysvn-1.6.3.ebuild:
+ version bumb and added version test
+
15 Oct 2008; Markus Rennings (mren) <mren@mrmx.de> -pysvn-1.6.1.ebuild,
+pysvn-1.6.2.ebuild:
Version bump
diff --git a/dev-python/pysvn/Manifest b/dev-python/pysvn/Manifest
index 436d91221..85634563e 100644
--- a/dev-python/pysvn/Manifest
+++ b/dev-python/pysvn/Manifest
@@ -1,4 +1,4 @@
-DIST pysvn-1.6.2.tar.gz 220638 RMD160 9f2268a2e8be763bffae70ba8966575c387134b8 SHA1 8e796ae1ab819b9d995974e97678395050cc3d24 SHA256 140c28fe9171cb231fb07c78066ccc74e316e20a63e3f1d5a7cdd10da3b7847e
-EBUILD pysvn-1.6.2.ebuild 1394 RMD160 cc87e6ea08de2cee0b5857a45f724b89afa404eb SHA1 9e3ae9e50d058479b17aab05d6283e6561fcc639 SHA256 f4427734e8f9da15b2adeb6f0729122012497e9b28c03eb7a236339d91f489d7
-MISC ChangeLog 1765 RMD160 e7b2e76ce87991e74530f39c8d3315636fee744d SHA1 f12185b98c6c3ef0bb90f38a0cab8270e28c3995 SHA256 97bf0ab1289757163bdfc59f3a1a85fb6e8eb12f66755b396f39b8c7e119ce7c
+DIST pysvn-1.6.3.tar.gz 310832 RMD160 aa2b1e02606fc01825eb8d35544863bf93f3ba88 SHA1 bcbc1313a0e832364bff87088e18b2bf1e6598c1 SHA256 85f514b98a5bc9e90c45e8d464940da20be3b2a43b7503fe3337863481918708
+EBUILD pysvn-1.6.3.ebuild 1645 RMD160 26057ff695f0e6b663b4c381dd3110d075205861 SHA1 9ca88864932fded835c57cd7b5ef9c2bc482d52e SHA256 0fa0ec0ba87a62347e37b30c14e5cc7ca166052a195e9b0f06bf18e2c2b04f07
+MISC ChangeLog 1901 RMD160 aa1231fe4eba856c9ccae380d32b3e20bce81bb0 SHA1 9c9ae982fe0e27b94fa890716dff47d470058e6c SHA256 3c7c46f0e87173975b859513bf62a2e44fe0f92e5e05ec2da6457f1d1e79b11e
MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/dev-python/pysvn/pysvn-1.6.2.ebuild b/dev-python/pysvn/pysvn-1.6.3.ebuild
index 1dfa865a9..f8fa08fa0 100644
--- a/dev-python/pysvn/pysvn-1.6.2.ebuild
+++ b/dev-python/pysvn/pysvn-1.6.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -19,9 +19,18 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}/${P}/Source"
src_unpack() {
+
+ python_version
+
unpack ${A}
cd "${S}"
+ # since pysvn-1.6.3: These sources are not compatible with python 2.5 - run
+ # the backport command to fix
+ if [[ "$PYVER_MAJOR" -lt 3 ]] && [[ "$PYVER_MINOR" -le 5 ]] ; then
+ python setup.py backport || die "backport failed"
+ fi
+
python setup.py configure || die "configure failed"
# we want our CFLAGS as well