summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/peg/peg-0.1.9.ebuild')
-rw-r--r--dev-util/peg/peg-0.1.9.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-util/peg/peg-0.1.9.ebuild b/dev-util/peg/peg-0.1.9.ebuild
new file mode 100644
index 000000000..92cb7b7ec
--- /dev/null
+++ b/dev-util/peg/peg-0.1.9.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Tools for generating recursive-descent parsers"
+HOMEPAGE="http://piumarta.com/software/peg/"
+SRC_URI="http://piumarta.com/software/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-Makefile.patch"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake PREFIX="${D}/usr" install
+}