summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/tinyxml/tinyxml-9999.ebuild')
-rw-r--r--dev-util/tinyxml/tinyxml-9999.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/dev-util/tinyxml/tinyxml-9999.ebuild b/dev-util/tinyxml/tinyxml-9999.ebuild
deleted file mode 100644
index 16caef2bc..000000000
--- a/dev-util/tinyxml/tinyxml-9999.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-ECVS_SERVER="tinyxml.cvs.sourceforge.net:/cvsroot/tinyxml"
-ECVS_MODULE="tinyxml"
-inherit eutils cvs
-
-DESCRIPTION="A simple C++ XML parser that can be easily integrating into other programs"
-HOMEPAGE="http://www.grinninglizard.com/tinyxml/index.html"
-SRC_URI=""
-
-LICENSE="GPL-2"
-KEYWORDS=""
-SLOT="0"
-IUSE="debug doc examples"
-
-DEPEND="dev-util/scons
- doc? ( app-doc/doxygen )"
-RDEPEND=""
-
-S="${WORKDIR}/${PN}"
-
-src_compile() {
- local myconf
-
- use debug && myconf="debug=0"
- scons ${MAKEOPTS} ${myconf} sharedlibrary=1 program=0 || die "scons failed"
- if use doc ; then
- doxygen dox || die "doxygen failed"
- fi
-}
-
-src_install () {
- insinto /usr/include
- doins *.h || die "installing headers failed"
- dolib libtinyxml.so || die "installing library failed"
- dodoc {changes,readme}.txt
- if use doc ; then
- dohtml docs/* || die "installing docs"
- fi
- if use examples ; then
- insinto /usr/share/doc/${PF}/samples
- doins *.xml xmltest.cpp || die "installing examples"
- fi
-}