summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/retrobattle/ChangeLog10
-rw-r--r--games-arcade/retrobattle/Manifest4
-rw-r--r--games-arcade/retrobattle/metadata.xml7
-rw-r--r--games-arcade/retrobattle/retrobattle-1.0.0.ebuild32
4 files changed, 53 insertions, 0 deletions
diff --git a/games-arcade/retrobattle/ChangeLog b/games-arcade/retrobattle/ChangeLog
new file mode 100644
index 000000000..d947af08a
--- /dev/null
+++ b/games-arcade/retrobattle/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for games-arcade/retrobattle
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*retrobattle-1.0.0 (02 Aug 2012)
+
+ 02 Aug 2012; Alexander Berntsen (alexander__b) <alexanderberntsen@linux.com>
+ +retrobattle-1.0.0.ebuild, +metadata.xml:
+ New ebuild games-arcade/retrobattle for bug 424273
+
diff --git a/games-arcade/retrobattle/Manifest b/games-arcade/retrobattle/Manifest
new file mode 100644
index 000000000..33174cec6
--- /dev/null
+++ b/games-arcade/retrobattle/Manifest
@@ -0,0 +1,4 @@
+DIST retrobattle-src-1.0.0.tar.bz2 4007959 SHA256 0d184c6d7afc2865687fb9323754268692db165799f617422aafd57096540d68 SHA512 2d006fc9a62e57d7fb3c0f0e535a5c702204b6341566064d7683526923839e8a43e14b308e76a8a1f6794f7c682f6344975956877f80bbcbc33ee61cd640ff9e WHIRLPOOL 0af965622d322a65ff3521ab816d208e4f8875a1620b9da51ddb1a4b39c97cbf7e305cf51ac3d27773b1bea43f254648dd846964fc9cec9eb3716f766e1f44cc
+EBUILD retrobattle-1.0.0.ebuild 751 SHA256 273426cedb8c489868d27bbc0a7187142290b3b99643d6add6b3287184b37150 SHA512 4eee7c77053de2d57b14e91ae752b9ab2dc8e2ec193aacf79d7631da55050ffb9d89bafc335414aca36e71cb56919d9610391274f627b108e9764c4995efc615 WHIRLPOOL b7258fa2c83a7fb867d76ca27b10c3a90995fbb0e5ea7d25a0f2b510bfeb2c7c127f2435b42c2c1ba48e14590b3294a362683644dbcd572d1d40d60041582927
+MISC ChangeLog 336 SHA256 032ae441ed078a50bb229d30970215f7aecac4298c1abd7688df3f278ee4bab5 SHA512 80f2e63085f676f2f8b86032f0753e5a38af1a8d29245a6f434723128a1a0d10853faedab22b07d5cdfbc5b1dc07e5f164596ddd0a995ebfd0727dac8539855a WHIRLPOOL bd5e5c1f7ac6f634b6d63a3e3fe4d324933355ebbde7eb8fb10532648cd96829acc3989e79af60a58f4d0c6b62ad8d689bc8d330382cd3be2c83f34deb2e0bad
+MISC metadata.xml 214 SHA256 c1f09dc7d5313cd2da7b82259c7846ed23144d62b15e59680ada90e2b6b4d154 SHA512 aeb2fb354a9ddf41c45a071091a58b91eaf8b25d6d2c49e3e3daa547b591a54530144de4533573160b48dc356289c909612c4e3c80e387f081f88cb39263e130 WHIRLPOOL 54d8861daedd18ca38e4ada0fb71026c612b63946d47a9b34de90d1d6d85c8ce05c0a4b97730f554ea637d73ccce8ed207d33e707c2b8c1dd28af24cf44dd186
diff --git a/games-arcade/retrobattle/metadata.xml b/games-arcade/retrobattle/metadata.xml
new file mode 100644
index 000000000..cc3fe2494
--- /dev/null
+++ b/games-arcade/retrobattle/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-wanted@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/games-arcade/retrobattle/retrobattle-1.0.0.ebuild b/games-arcade/retrobattle/retrobattle-1.0.0.ebuild
new file mode 100644
index 000000000..5fda10409
--- /dev/null
+++ b/games-arcade/retrobattle/retrobattle-1.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit games
+
+DESCRIPTION="A NES-like platform arcade game"
+HOMEPAGE="http://remar.se/andreas/retrobattle/"
+SRC_URI="${HOMEPAGE}files/${PN}-src-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ media-libs/libsdl
+ media-libs/sdl-mixer
+ "
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${PN}-src-${PV}/src/
+
+src_install() {
+ emake RETROINSTALLDIR="${D}/${GAMES_DATADIR}" install || die "emake failed"
+ prepgamesdirs
+ # Following games.eclass the binary should be in /usr/games/bin/
+ dosym "${GAMES_DATADIR}/${PN}/${PN}" "${GAMES_PREFIX}/bin/${PN}" || die "dosym failed"
+ dodoc "../manual.txt" "../README"
+}