summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-engines/dagii/dagii-0.3.ebuild')
-rw-r--r--games-engines/dagii/dagii-0.3.ebuild8
1 files changed, 2 insertions, 6 deletions
diff --git a/games-engines/dagii/dagii-0.3.ebuild b/games-engines/dagii/dagii-0.3.ebuild
index 17b7206b8..a7a34fae0 100644
--- a/games-engines/dagii/dagii-0.3.ebuild
+++ b/games-engines/dagii/dagii-0.3.ebuild
@@ -17,14 +17,9 @@ DEPEND="png? ( media-libs/libpng )
media-libs/libsdl"
RDEPEND="${DEPEND}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/${P}-depend.1.diff"
-}
-
src_compile() {
egamesconf $(use_enable png libpng ) || die "econf failed"
+ emake dep || die "emake dep failed"
emake || die "emake failed"
}
@@ -41,5 +36,6 @@ pkg_postinst() {
elog "or in a location passed as a path in the command line"
elog "For example: \"$ dagii /usr/share/games/kq3\""
elog "Also, dagii can play games which are stored in .zip archives."
+ echo
games_pkg_postinst
}