summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/postal2mp/ChangeLog4
-rw-r--r--games-fps/postal2mp/Manifest4
-rw-r--r--games-fps/postal2mp/postal2mp-1409.ebuild17
3 files changed, 17 insertions, 8 deletions
diff --git a/games-fps/postal2mp/ChangeLog b/games-fps/postal2mp/ChangeLog
index e351a76cf..903c1bfd1 100644
--- a/games-fps/postal2mp/ChangeLog
+++ b/games-fps/postal2mp/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 20 May 2010; Laurento Frittella (mrfree) <laurento.frittella@gmail.com>
+ postal2mp-1409.ebuild:
+ amd64 added
+
11 May 2010; Laurento Frittella (mrfree) <laurento.frittella@gmail.com>
+postal2mp-1409.ebuild, +metadata.xml:
New Ebuild for bug 319125 thanks to Tommy[D]
diff --git a/games-fps/postal2mp/Manifest b/games-fps/postal2mp/Manifest
index 6abde5d06..1add9bb1c 100644
--- a/games-fps/postal2mp/Manifest
+++ b/games-fps/postal2mp/Manifest
@@ -1,4 +1,4 @@
DIST postal2mp-1409.tar.bz2 591082047 RMD160 3b4101f12246db3d42c8f7ef8f3d12abbcea0116 SHA1 24db3f23c3ffdb3e9f558ffe4ae5682aa5dc9361 SHA256 9869c6ffc220e58cb51eb04c5dbbc480d5025cfd33b83bf4f3eb8ac340d6c1e2
-EBUILD postal2mp-1409.ebuild 1148 RMD160 2eb42ea15410f0b64f22bf11b478860b58744e71 SHA1 41be2ee840e9da04b790938012f0b2053c633846 SHA256 462df5ced07b805f0bbd5fb25dd8087c0c45a7c8e523d9b11c3efc9a7b88a29d
-MISC ChangeLog 283 RMD160 42f3909a73d7621535d7ae9c4aeb62973ed3f986 SHA1 781a368e4ad891167179b1730664df6d397e2c23 SHA256 fd9423fbffdb3055c9836076978df71d6ac77deccd8d11adb24640db1f053b18
+EBUILD postal2mp-1409.ebuild 1276 RMD160 64cd0808dcd331326026cb849194ad31b815ae50 SHA1 cd7a1396d1b13dc6824f693a88442fe06121a581 SHA256 51e51c30c22d7b35bacbac08a4a0858c12f7a686e37ec74d42019004c11cfa61
+MISC ChangeLog 397 RMD160 a3f2d5f5b7e9f29cde63a66e00e08a613dd7b8f9 SHA1 b0112fa99d55f77689e23beaef3620f71b73470c SHA256 7cdcc29fb8efe3feead1000dab2e31335bd5c395c8e6dc341a44493595ba28e5
MISC metadata.xml 229 RMD160 f0f6417bec31ce8baba6d476664f7210c8c84c98 SHA1 e5f94f5caadc6f843fc90bb7959570cd503676fd SHA256 3b08fca3c878bdfc4e7639f477dd542d55a4ab5dce39a475e82633071d13eb3f
diff --git a/games-fps/postal2mp/postal2mp-1409.ebuild b/games-fps/postal2mp/postal2mp-1409.ebuild
index a7def7c8c..f8785bc5a 100644
--- a/games-fps/postal2mp/postal2mp-1409.ebuild
+++ b/games-fps/postal2mp/postal2mp-1409.ebuild
@@ -3,7 +3,7 @@
# $Header: $
EAPI=2
-inherit eutils games
+inherit eutils games multilib
DESCRIPTION="Postal 2: Share the Pain - Free Multiplayer Edition"
HOMEPAGE="http://icculus.org/news/news.php?id=4419"
@@ -11,27 +11,32 @@ SRC_URI="http://0day.icculus.org/postal2/Postal2STP-FreeMP-linux.tar.bz2 -> ${P}
LICENSE="postal2stp-freemp"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="~amd64 ~x86"
IUSE=""
RESTRICT="strip"
PROPERTIES="interactive"
RDEPEND="virtual/opengl
- media-libs/libsdl[X,opengl]
- media-libs/openal"
+ amd64? ( app-emulation/emul-linux-x86-sdl )
+ x86? (
+ media-libs/libsdl[X,opengl]
+ media-libs/openal
+ )"
GAMES_CHECK_LICENSE="yes"
S=${WORKDIR}/Postal2STP-FreeMP-linux
src_install() {
+ has_multilib_profile && ABI=x86
+
dir=${GAMES_PREFIX_OPT}/${PN}
insinto "${dir}"
doins -r Animations KarmaData Maps Music Sounds \
StaticMeshes System Textures Web || die "doins failed"
- dosym /usr/lib/libopenal.so "${dir}"/System/openal.so || die
- dosym /usr/lib/libSDL-1.2.so.0 "${dir}"/System/libSDL-1.2.so.0 || die
+ dosym /usr/$(get_libdir)/libopenal.so "${dir}"/System/openal.so || die
+ dosym /usr/$(get_libdir)/libSDL-1.2.so.0 "${dir}"/System/libSDL-1.2.so.0 || die
fperms +x "${dir}"/System/postal2-bin || die "fperms failed"