summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-util/etswitch/etswitch-0.1.14.ebuild')
-rw-r--r--games-util/etswitch/etswitch-0.1.14.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/games-util/etswitch/etswitch-0.1.14.ebuild b/games-util/etswitch/etswitch-0.1.14.ebuild
new file mode 100644
index 000000000..64cc28a7f
--- /dev/null
+++ b/games-util/etswitch/etswitch-0.1.14.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="A 'minimizer' for a few games."
+HOMEPAGE="http://hem.bredband.net/b400150"
+SRC_URI="http://hem.bredband.net/b400150/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="debug"
+
+DEPEND="|| ( ( x11-libs/libX11
+ x11-libs/libXmu
+ x11-libs/libXxf86vm
+ x11-libs/libXt
+ x11-libs/libXpm )
+ <virtual/x11-7.0 )"
+
+src_compile() {
+ econf \
+ $(use_enable debug) || die "econf failed."
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS BUGS ChangeLog NEWS README TODO
+}
+