summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-radio/grig/grig-0.7.2.ebuild')
-rw-r--r--media-radio/grig/grig-0.7.2.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/media-radio/grig/grig-0.7.2.ebuild b/media-radio/grig/grig-0.7.2.ebuild
index 33dc24f4b..13a3cc56b 100644
--- a/media-radio/grig/grig-0.7.2.ebuild
+++ b/media-radio/grig/grig-0.7.2.ebuild
@@ -3,7 +3,7 @@
# $Header: $
EAPI="1"
-inherit eutils
+inherit autotools eutils
DESCRIPTION="A tool for controlling amateur radios"
HOMEPAGE="http://groundstation.sourceforge.net/grig/"
@@ -11,7 +11,7 @@ SRC_URI="mirror://sourceforge/groundstation/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~ppc"
+KEYWORDS="~ppc ~x86"
IUSE="coverage +hardware"
DEPEND=">=dev-libs/glib-2.6
@@ -19,6 +19,14 @@ DEPEND=">=dev-libs/glib-2.6
>=media-libs/hamlib-1.2.5"
RDEPEND="${DEPEND}"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ #patch to support old GtkTooltips above gtk+-2.12
+ epatch "${FILESDIR}/${P}-Tooltip.patch"
+ eautoreconf
+}
+
src_compile() {
local myconf
use hardware || myconf="${myconf} --disable-hardware"