summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/pytivo-wmcbrine/ChangeLog8
-rw-r--r--media-tv/pytivo-wmcbrine/Manifest5
-rw-r--r--media-tv/pytivo-wmcbrine/files/pyTivo.initd.sh31
-rw-r--r--media-tv/pytivo-wmcbrine/metadata.xml5
-rw-r--r--media-tv/pytivo-wmcbrine/pytivo-wmcbrine-20090908.ebuild60
5 files changed, 109 insertions, 0 deletions
diff --git a/media-tv/pytivo-wmcbrine/ChangeLog b/media-tv/pytivo-wmcbrine/ChangeLog
new file mode 100644
index 000000000..39b7eeb74
--- /dev/null
+++ b/media-tv/pytivo-wmcbrine/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for media-tv/pytivo-wmcbrine
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 13 Sep 2009; John Ratliff (jdratlif) <webmaster@technoplaza.net>
+ +pytivo-wmcbrine-20090908.ebuild, +files/pyTivo.initd.sh, +metadata.xml:
+ New Ebuild for bug 284737 thanks to _AxS_, desultory, ohnobinki, and Obeliks
+
diff --git a/media-tv/pytivo-wmcbrine/Manifest b/media-tv/pytivo-wmcbrine/Manifest
new file mode 100644
index 000000000..ed4b94284
--- /dev/null
+++ b/media-tv/pytivo-wmcbrine/Manifest
@@ -0,0 +1,5 @@
+AUX pyTivo.initd.sh 541 RMD160 a33d02249b3762cdc37c9d33c766811a4bf3a6a9 SHA1 03cc21afd6e021ecbc7596236f34bb376735ca4f SHA256 6a8f5c7e4d8328b8bb1cef595e51e0564cabb19c913571967e51d6cf5bcb89af
+DIST pytivo-wmcbrine-20090908.tar.gz 362404 RMD160 2909c33b322f79b7023e81c7f09d69caa08906eb SHA1 db2af927c471312c15fe91c9d09f00b24589c12c SHA256 ba95f478509dc9ae3a15492a6c4a2df1c76c47d32ca8e82d68f1f2163fc2e5ea
+EBUILD pytivo-wmcbrine-20090908.ebuild 1527 RMD160 e17d75c3136c3558349ed268cf538081d11cc335 SHA1 05e22d595407fe7a738c5fc062302c61cf211ead SHA256 b7d19c4f98722112caaa980d1f4d773ff5cf130780705ff1afcde74eaeede95b
+MISC ChangeLog 347 RMD160 77eab041a90369912b3f9577c4a5c2fea5b2a251 SHA1 744a6cb469553b3d3704b98877dc37d442abad59 SHA256 1928ea2af2d2c7622eb93fa64613f82138b4cd238a54a1b9a7986649aaabe5a0
+MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/media-tv/pytivo-wmcbrine/files/pyTivo.initd.sh b/media-tv/pytivo-wmcbrine/files/pyTivo.initd.sh
new file mode 100644
index 000000000..00aa9e905
--- /dev/null
+++ b/media-tv/pytivo-wmcbrine/files/pyTivo.initd.sh
@@ -0,0 +1,31 @@
+#!/sbin/runscript
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+depend() {
+ need localmount net
+ after bootmisc
+}
+
+start() {
+ ebegin "Starting pyTivo"
+ start-stop-daemon --start --exec /usr/bin/pytivo \
+ --pidfile /var/run/pytivo.pid -m -N 19 -c pytivo:pytivo \
+ -- > /dev/null 2>&1 &
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping pyTivo"
+ start-stop-daemon --stop --exec /usr/bin/pytivo \
+ --pidfile /var/run/pytivo.pid
+ eend $?
+}
+
+restart() {
+ stop
+ sleep 2
+ start
+}
+
diff --git a/media-tv/pytivo-wmcbrine/metadata.xml b/media-tv/pytivo-wmcbrine/metadata.xml
new file mode 100644
index 000000000..7e3286984
--- /dev/null
+++ b/media-tv/pytivo-wmcbrine/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>maintainer-wanted</herd>
+</pkgmetadata>
diff --git a/media-tv/pytivo-wmcbrine/pytivo-wmcbrine-20090908.ebuild b/media-tv/pytivo-wmcbrine/pytivo-wmcbrine-20090908.ebuild
new file mode 100644
index 000000000..1d907ea83
--- /dev/null
+++ b/media-tv/pytivo-wmcbrine/pytivo-wmcbrine-20090908.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+NEED_PYTHON=2.4
+
+inherit eutils multilib python
+
+DESCRIPTION="An HMO and GoBack server for Tivo."
+HOMEPAGE="http://pytivo.sourceforge.net/"
+SRC_URI="http://repo.or.cz/w/pyTivo/wmcbrine.git?a=snapshot;h=ebd6eeb6229401398f2d040ce404b86ce409fed0;sf=tgz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="media-video/ffmpeg"
+
+S="${WORKDIR}/wmcbrine"
+
+pkg_setup() {
+ enewgroup pytivo
+ enewuser pytivo -1 -1 -1 pytivo
+}
+
+src_install() {
+ MY_LIBDIR="/usr/$(get_libdir)/${PN}"
+
+ insinto $MY_LIBDIR
+ doins *.py *.pyw || die "Install failed"
+ doins -r Cheetah mutagen plugins templates xmpp || die "Install failed"
+
+ fperms 0755 ${MY_LIBDIR}/pyTivo.py || die "Cannot set permissions"
+
+ newinitd "${FILESDIR}"/pyTivo.initd.sh pytivo \
+ || die "Cannot create init.d launcher"
+
+ dodoc README || die "Cannot install docs"
+ newdoc pyTivo.conf.dist pyTivo.conf || die "Cannot install docs"
+
+ dosym ${MY_LIBDIR}/pyTivo.py /usr/bin/pytivo \
+ || die "Cannot create symlink to launcher"
+}
+
+pkg_postinst() {
+ ewarn "You must setup /etc/pyTivo.conf before pyTivo can be started. A"
+ ewarn "sample configuration file pyTivo.conf is available in"
+ ewarn "/usr/share/doc/${PF}"
+ ewarn
+
+ elog "pyTivo can be run as a normal user or it can be started"
+ elog "automatically by adding pytivo to the default runlevel by"
+ elog " # rc-update add pytivo default"
+ elog "as root."
+}
+