summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/icinga/ChangeLog3
-rw-r--r--net-analyzer/icinga/Manifest3
-rw-r--r--net-analyzer/icinga/icinga-1.0.3-r1.ebuild204
3 files changed, 209 insertions, 1 deletions
diff --git a/net-analyzer/icinga/ChangeLog b/net-analyzer/icinga/ChangeLog
index 436b4ed9c..4bc745e35 100644
--- a/net-analyzer/icinga/ChangeLog
+++ b/net-analyzer/icinga/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 23 Sep 2010; mthode <mthode@mthode.org> +icinga-1.0.3-r1.ebuild:
+ updated ebuild cleanup thanks to Tommy[D] and sedzimir
+
10 Sep 2010; mthode <mthode@mthode.org> icinga-1.0.3.ebuild,
files/icinga-conf.d, files/icinga-init.d, -files/metadata.xml:
New version of icinga, cleaner, thanks to Tommy[D] and chithead
diff --git a/net-analyzer/icinga/Manifest b/net-analyzer/icinga/Manifest
index 5b25c95f0..efd6bc65b 100644
--- a/net-analyzer/icinga/Manifest
+++ b/net-analyzer/icinga/Manifest
@@ -5,6 +5,7 @@ AUX icinga-lighty.conf 465 RMD160 34de76ad07f95e2282ae3e192b35cd9310ef2b4e SHA1
AUX ido2db-conf.d 35 RMD160 a2bb1738720a56285da529fb18eeb60739ac817b SHA1 57ba29aec3f80db9577da4aca34d228487dd12c1 SHA256 6cbdf0eb7070121bd466c221d73cf6ca05a4af5caa1d4abedf62828edd1b1372
AUX ido2db-init.d 539 RMD160 e89e70f67d5accc7ae66b77d9bf61d2e1cc9d647 SHA1 17f9317bd21a5e5dfd41bbb19f50357b80ba9599 SHA256 e5b6a782475cbbde5b49720cdbcbf14958338baca510e78e508902360a479b72
DIST icinga-1.0.3.tar.gz 8583094 RMD160 74bb5022eb6708477128a418baec5324b7f07311 SHA1 07edc061fe88d36366a3408d7138699c287673df SHA256 ae67d10f81767b224fc2768ee58a328c88eda62676fcf5b26fee75e2f79939cd
+EBUILD icinga-1.0.3-r1.ebuild 5792 RMD160 7aea0982d278d8b84140235da9d3a5a0375b899d SHA1 45dbdf09ad1050d31cb48e49cfad9cd481d88fe4 SHA256 9b41d0db8189253c37da99f72003291ddd40d5bce002f8e056716f699a5041d5
EBUILD icinga-1.0.3.ebuild 6359 RMD160 9a3a7ebaac53dfc2b685e18bc4ead7885d2930fa SHA1 b5b364fbc1f4486946a6372cb05ce2dc4136fad9 SHA256 daed5fae1f604434c31c7de8ab4fe8ba8f783b189ec30f23269aa9152f5b9b13
-MISC ChangeLog 928 RMD160 9fd6886f12242a9a780c2402ab0cb2455ea9c463 SHA1 d098d6beafbe4992669e8b6d5ea638c1125ace41 SHA256 ca88a90240c9885d19f1f83a492cfcb62254c0e5046844223be6ba0d6de82a91
+MISC ChangeLog 1053 RMD160 e14ab62d68d08d91dcc2dd1f7f3f37b77a125c2e SHA1 47f840044028e9f92de17799a42eb8b0a9fe7f29 SHA256 92a4a46e59ece6ee0db3324b0efcf053d0c880eda74e24d971a59730502f8dd6
MISC metadata.xml 617 RMD160 48225567d6faa1646f8600b2c2a924bfecb34bfe SHA1 1332e6a76891016de22c669c834ffbc47d0986a1 SHA256 c97b32c33007fddc24119f96f12df720da5232bb459e5f1c3970e658fd08089e
diff --git a/net-analyzer/icinga/icinga-1.0.3-r1.ebuild b/net-analyzer/icinga/icinga-1.0.3-r1.ebuild
new file mode 100644
index 000000000..6cdb9f499
--- /dev/null
+++ b/net-analyzer/icinga/icinga-1.0.3-r1.ebuild
@@ -0,0 +1,204 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit eutils depend.apache toolchain-funcs
+
+DESCRIPTION="Nagios Fork - Check daemon, CGIs, docs, IDOutils"
+HOMEPAGE="http://www.icinga.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+apache2 api debug +idoutils lighttpd +mysql perl plugins postgres ssl +vim-syntax +web"
+DEPEND="idoutils? ( dev-db/libdbi-drivers[mysql?,postgres?] )
+ perl? ( dev-lang/perl )
+ virtual/mailx
+ web? (
+ media-libs/gd[jpeg,png]
+ lighttpd? ( www-servers/lighttpd dev-lang/php[cgi] )
+ apache2? ( || ( dev-lang/php[apache2] dev-lang/php[cgi] ) )
+ )
+ !net-analyzer/nagios-core"
+RDEPEND="${DEPEND}
+ plugins? ( net-analyzer/nagios-plugins )
+ vim-syntax? ( app-vim/nagios-syntax )"
+
+want_apache2
+
+pkg_setup() {
+ enewgroup icinga
+ enewuser icinga -1 /bin/false /var/spool/icinga icinga
+ if use web ; then
+ elog "This does not include cgis that are perl-dependent"
+ elog "Currently traceroute.cgi is perl-dependent"
+ elog "To have ministatus.cgi requires copying of ministatus.c"
+ elog "to cgi directory for compiling."
+
+ elog "Note that the user your webserver is running at needs"
+ elog "read-access to /etc/icinga."
+ elog
+
+ if use apache2 || use lighttpd ; then
+ elog "There are several possible solutions to accomplish this,"
+ elog "choose the one you are most comfortable with:"
+ elog
+ if use apache2 ; then
+ elog " usermod -G icinga apache"
+ elog "or"
+ elog " chown icinga:apache /etc/icinga"
+ elog
+ elog "Also edit /etc/conf.d/apache2 and add \"-D ICINGA\""
+ elif use lighttpd ; then
+ elog " usermod -G icinga lighttpd "
+ elog "or"
+ elog " chown icinga:lighttpd /etc/icinga"
+ fi
+ elog
+ elog "That will make icinga's web front end visable via"
+ elog "http://localhost/icinga/"
+ elog
+ else
+ elog "IMPORTANT: Do not forget to add the user your webserver"
+ elog "is running as to the icinga group!"
+ fi
+
+ else
+ ewarn "Please note that you have installed Icinga without web interface."
+ ewarn "Please don't file any bugs about having no web interface when you do this."
+ ewarn "Thank you!"
+ fi
+
+}
+
+src_prepare() {
+ if use api ; then
+ sed -i -e 's/\(USE_ICINGAAPI=\)no/\1yes/g' Makefile.in || die "sed failed in Makefile.in"
+ fi
+}
+
+src_configure() {
+ local myconf
+
+ myconf="$(use_enable perl embedded-perl)
+ $(use_with perl perlcache)
+ $(use_enable idoutils)
+ $(use_enable ssl)
+ $(use_enable debug DEBUG0)
+ $(use_enable debug DEBUG1)
+ $(use_enable debug DEBUG2)
+ $(use_enable debug DEBUG3)
+ $(use_enable debug DEBUG4)
+ $(use_enable debug DEBUG5)
+ --disable-statuswrl
+ --bindir=/usr/sbin
+ --sbindir=/usr/$(get_libdir)/icinga/cgi-bin
+ --datarootdir=/usr/share/icinga/htdocs
+ --localstatedir=/var/icinga
+ --sysconfdir=/etc/icinga
+ --libexecdir=/usr/$(get_libdir)/icinga/plugins"
+
+ if use !apache2 && use !lighttpd ; then
+ myconf+=" --with-command-group=icinga"
+ else
+ if use apache2 ; then
+ myconf+=" --with-command-group=apache --with-httpd-conf=/etc/apache2/conf.d"
+ elif use lighttpd ; then
+ myconf+=" --with-command-group=lighttpd"
+ fi
+ fi
+
+ econf ${myconf}
+ if use api ; then
+ cd module/icinga-api
+ econf ${myconf}
+ fi
+}
+
+src_compile() {
+ tc-export CC
+
+ emake icinga || die "make failed"
+
+ if use web ; then
+ emake DESTDIR="${D}" cgis || die
+ fi
+
+ if use idoutils ; then
+ emake DESTDIR="${D}" idoutils || die
+ fi
+}
+
+src_install() {
+ dodoc Changelog README UPGRADING || die
+
+ if ! use web ; then
+ sed -i -e '/cd $(SRC_\(CGI\|HTM\))/d' Makefile || die
+ fi
+ sed -i -e 's/^contactgroups$//g' Makefile || die
+
+ emake DESTDIR="${D}" install{,-config,-commandmode} || die
+
+ if use idoutils ; then
+ emake DESTDIR="${D}" install-idoutils || die
+ fi
+ if use api ; then
+ emake DESTDIR="${D}" install-api || die
+ fi
+
+ newinitd "${FILESDIR}"/icinga-init.d icinga || die
+ newconfd "${FILESDIR}"/icinga-conf.d icinga || die
+ if use idoutils ; then
+ newinitd "${FILESDIR}"/ido2db-init.d ido2db || die
+ newconfd "${FILESDIR}"/ido2db-conf.d ido2db || die
+ insinto /usr/share/icinga/contrib/db
+ doins -r module/idoutils/db/* || die
+ fi
+ # Apache Module
+ if use web ; then
+ if use apache2 ; then
+ insinto "${APACHE_MODULES_CONFDIR}"
+ newins "${FILESDIR}"/icinga-apache.conf 99_icinga.conf || die
+ elif use lighttpd ; then
+ insinto /etc/lighttpd
+ newins "${FILESDIR}"/icinga-lighty.conf lighttpd_icinga.conf || die
+ else
+ ewarn "${CATEGORY}/${PF} only supports Apache-2.x or Lighttpd webserver"
+ ewarn "out-of-the-box. Since you are not using one of them, you"
+ ewarn "have to configure your webserver accordingly yourself."
+ fi
+
+ fi
+
+ fowners -R icinga:icinga /etc/icinga /var/icinga || die "Failed chown of /etc/icinga"
+
+ fowners -R root:root /usr/$(get_libdir)/icinga
+ find "${D}"/usr/$(get_libdir)/icinga -type d -exec fperms 755 {} +
+ find "${D}"/usr/$(get_libdir)/icinga/cgi-bin -type f -exec fperms 755 {} +
+
+ keepdir /etc/icinga
+ keepdir /var/icinga
+ keepdir /var/icinga/archives
+ keepdir /var/icinga/rw
+ keepdir /var/icinga/spool/checkresults
+
+ use apache2 && webserver=apache2 || use lighttpd && webserver=lighttpd || webserver=icinga
+ fowners -R icinga:${webserver} /var/icinga/rw || die "Failed chown of /var/icinga/rw"
+
+ fperms 6755 /var/icinga/rw || die "Failed Chmod of ${D}/var/icinga/rw"
+ fperms 0750 /etc/icinga || die "Failed chmod of ${D}/etc/icinga"
+}
+
+pkg_postinst() {
+ elog "If you want icinga to start at boot time"
+ elog "remember to execute:"
+ elog " rc-update add icinga default"
+ elog
+ elog "If your kernel has /proc protection, icinga"
+ elog "will not be happy as it relies on accessing the proc"
+ elog "filesystem. You can fix this by adding icinga into"
+ elog "the group wheel, but this is not recomended."
+}