summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/ldns/ldns-1.5.1.ebuild')
-rw-r--r--net-libs/ldns/ldns-1.5.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-libs/ldns/ldns-1.5.1.ebuild b/net-libs/ldns/ldns-1.5.1.ebuild
new file mode 100644
index 000000000..1379d5b46
--- /dev/null
+++ b/net-libs/ldns/ldns-1.5.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header$
+
+DESCRIPTION="ldns is a library with the aim to simplify DNS programing in C"
+HOMEPAGE="http://www.nlnetlabs.nl/projects/ldns/"
+SRC_URI="http://www.nlnetlabs.nl/downloads/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="dev-libs/openssl"
+RDEPEND=${DEPEND}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc Changelog README || die "dodoc failed"
+
+ if use examples; then
+ docinto examples
+ dodoc examples/* || die "dodoc for examples failed"
+ fi
+}
+
+pkg_postinst() {
+ ewarn "The drill binary and the ldns-* utilities were moved into their own"
+ ewarn "package. If you need them, install net-dns/ldns-utils."
+}