summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/gmail-notify')
-rw-r--r--net-mail/gmail-notify/ChangeLog7
-rw-r--r--net-mail/gmail-notify/Manifest6
-rw-r--r--net-mail/gmail-notify/gmail-notify-1.6.1.1.ebuild56
-rw-r--r--net-mail/gmail-notify/gmail-notify-1.6.1.ebuild58
4 files changed, 65 insertions, 62 deletions
diff --git a/net-mail/gmail-notify/ChangeLog b/net-mail/gmail-notify/ChangeLog
index 08ac3354d..3ef524060 100644
--- a/net-mail/gmail-notify/ChangeLog
+++ b/net-mail/gmail-notify/ChangeLog
@@ -1,7 +1,12 @@
# ChangeLog for net-mail/gmail-notify
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 01 Jun 2009; Ian Stakenvicius (_AxS_) <ian@aerobiology.ca>
+ -gmail-notify-1.6.1.ebuild, +gmail-notify-1.6.1.1.ebuild:
+ Version bump, added keyword, fixed bug relating to revdep-rebuild, and
+ improved ebuild form thanks to idl0r
+
07 Jan 2007; Jakub Moc <jakub@gentoo.org> gmail-notify-1.6.1.ebuild:
Make this multilib friendly
diff --git a/net-mail/gmail-notify/Manifest b/net-mail/gmail-notify/Manifest
index 083ba3d14..8d41c9c6e 100644
--- a/net-mail/gmail-notify/Manifest
+++ b/net-mail/gmail-notify/Manifest
@@ -1,7 +1,7 @@
AUX gmail-notify-conf-perms.patch 571 RMD160 d4b9805cd595a9da0d7b08e534ef0f825dc682ae SHA1 afa23b7806413ed7b6a2acc8b3ba7cac8fed2895 SHA256 aef0e1e72c8037897ae1ba50bb757a1e3cb3382ea886169e1a3ecc7b47f8f48d
AUX gmail-notify-trayicon.patch 696 RMD160 51b69fedf84f3b9b7ad88dc70809bd1c88ef065e SHA1 89c6a6766a3a0d04de4218bddaf36746357ce067 SHA256 856e020a4604880050fea5d1137273720e75545d49cc950de75e2d90076ba1cf
AUX gmail-notify-ubuntu-patches.patch 1884 RMD160 af0d473d2c85980d1d1d47cbda5e75a5144ee8db SHA1 41ff1de962a762a5ccf632e52fa0a81a3ce7972c SHA256 48d30024c402eea2311a4950f04bf1fde5e202a5deaae5ad160d5c9d8897bf78
-DIST gmail-notify-1.6.1.tar.gz 26348 RMD160 2589814c80d808449310315c7cb9c4c7fe01e05e SHA1 8f5c075607b3e5c4f71a7ecc8c717d8736f37462 SHA256 e97c69a60443bf24c1bc404e85f4fe2bb525e91e80e7d6b5d710b00dcc51507d
-EBUILD gmail-notify-1.6.1.ebuild 1548 RMD160 cbca1674f8c4e8a0eeb6af7843c05b5999d4c41a SHA1 4c071971e446d65ef3ffa0807dcf85aef6aa7a0d SHA256 60a361385fa23351a163790a823221ac5467abd91baa1a68ebf074225756e18e
-MISC ChangeLog 1294 RMD160 e52b7e4926deb6480dd0ef230243668c9debc61f SHA1 f2f99c732595312d43f3ca0b9c15f591fc51717a SHA256 7aab148a2d23176384e80fdcc9aa77d1089646ebf5b252f193583eb8f6d60e09
+DIST gmail-notify-1.6.1.1.tar.gz 32167 RMD160 4e7234071a314fbfb5d9e3cdea45937c5fd6335d SHA1 db21798a90a1f1b09fa30cdae48069ba767636ee SHA256 96aa835c04a12d700621a7010c300f2146ca212aaebe92d2b8e8158024999de0
+EBUILD gmail-notify-1.6.1.1.ebuild 1401 RMD160 a53357a732ab723e87ce66bcee1eeb8eca310f89 SHA1 8fe3375eeb7651a6a42880874c80b39ae62f1444 SHA256 d964db715cfbed9ed4638b66e5ebef63cef3c1a4d20a4babfd5e5eb4f38dc315
+MISC ChangeLog 1528 RMD160 85fe0b46a270295973cd144bf5b291e7df4930c4 SHA1 dfe93dc00c99493a1eca4d9b518490df3a821581 SHA256 f2712b6dae4462b5aac8463967092ee1a73b3bd996fc143ecc0ff9724226a22e
MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/net-mail/gmail-notify/gmail-notify-1.6.1.1.ebuild b/net-mail/gmail-notify/gmail-notify-1.6.1.1.ebuild
new file mode 100644
index 000000000..f2a8713f4
--- /dev/null
+++ b/net-mail/gmail-notify/gmail-notify-1.6.1.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit python eutils
+
+DESCRIPTION="A notification applet for Gmail that's alternative to the one released from Google"
+HOMEPAGE="http://gmail-notify.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/gnome-python-extras
+ >=dev-python/pygtk-2.0"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ python_version
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-conf-perms.patch" \
+ "${FILESDIR}/${PN}-trayicon.patch" \
+ "${FILESDIR}/${PN}-ubuntu-patches.patch"
+
+ # substitute the "GENTOO_PYVER" that was added by ${PN}-ubuntu-patches.patch
+ sed -i -e "s/GENTOO_PYVER/${PYVER}/g" *.py || die "Sed broke!"
+}
+
+src_install() {
+ python_version
+ local instdir=$(python_get_sitedir)/${PN}
+
+ dodoc README || die
+
+ insinto "${instdir}"
+ doins *.py *.jpg *.png langs.xml notifier.conf.sample || die
+
+ make_wrapper gmail-notify "${python} ${instdir}/notifier.py"
+}
+
+pkg_postinst() {
+ python_mod_optimize "$(python_get_sitedir)/${PN}"
+ einfo
+ einfo "Run gmail-notify to start the program"
+ einfo
+ ewarn "Warning: if you check the 'save username and password' option"
+ ewarn "your password will be stored in plaintext in ~/.notifier.conf"
+}
+
+pkg_postrm() {
+ python_mod_cleanup "$(python_get_sitedir)/${PN}"
+}
diff --git a/net-mail/gmail-notify/gmail-notify-1.6.1.ebuild b/net-mail/gmail-notify/gmail-notify-1.6.1.ebuild
deleted file mode 100644
index d71c25f80..000000000
--- a/net-mail/gmail-notify/gmail-notify-1.6.1.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-inherit python eutils multilib
-
-DESCRIPTION="Gmail Notifier is a Linux alternative for the notifier program released by Google"
-HOMEPAGE="http://gmail-notify.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-LICENSE="GPL-2"
-
-SLOT="0"
-KEYWORDS="~x86"
-IUSE=""
-RESTRICT="strip"
-
-RDEPEND="dev-python/gnome-python-extras
- >=dev-python/pygtk-2.0"
-DEPEND="${RDEPEND}"
-
-S=${WORKDIR}/${PN}
-
-src_unpack() {
- python_version
- unpack ${A}
- epatch "${FILESDIR}/${PN}-conf-perms.patch"
- epatch "${FILESDIR}/${PN}-trayicon.patch"
- epatch "${FILESDIR}/${PN}-ubuntu-patches.patch"
- cd "${S}"
- sed -i -e "s/GENTOO_PYVER/${PYVER}/g" notifier.py || die "Sed broke!"
- sed -i -e "s/GENTOO_PYVER/${PYVER}/g" GmailConfig.py || die "Sed broke!"
-}
-
-src_install() {
- python_version
- INST_DIR=/usr/$(get_libdir)/python${PYVER}/site-packages/${PN}
-
- dodoc README
-
- insinto ${INST_DIR}
- doins *.py *.jpg *.png langs.xml pytrayicon.so notifier.conf.sample
-
- make_wrapper gmail-notify "/usr/bin/python ${INST_DIR}/notifier.py"
-}
-
-pkg_postinst() {
- python_version
- python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/${PN}
- elog "Run gmail-notify to start the program"
- elog ""
- elog "Warning: if you check the 'save username and password' option"
- elog "your password will be stored in plaintext in ~/.notifier.conf"
-}
-
-pkg_postrm() {
- python_version
- python_mod_cleanup /usr/$(get_libdir)/python${PYVER}/site-packages/${PN}
-}