summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/apt-cacher-ng/files')
-rw-r--r--net-misc/apt-cacher-ng/files/apt-cacher-ng-0.3.8-respect-portage-qa-build-unstripped.patch36
-rw-r--r--net-misc/apt-cacher-ng/files/confd2
-rw-r--r--net-misc/apt-cacher-ng/files/cron.daily15
-rw-r--r--net-misc/apt-cacher-ng/files/initd32
-rw-r--r--net-misc/apt-cacher-ng/files/logrotate15
5 files changed, 100 insertions, 0 deletions
diff --git a/net-misc/apt-cacher-ng/files/apt-cacher-ng-0.3.8-respect-portage-qa-build-unstripped.patch b/net-misc/apt-cacher-ng/files/apt-cacher-ng-0.3.8-respect-portage-qa-build-unstripped.patch
new file mode 100644
index 000000000..2502fd92b
--- /dev/null
+++ b/net-misc/apt-cacher-ng/files/apt-cacher-ng-0.3.8-respect-portage-qa-build-unstripped.patch
@@ -0,0 +1,36 @@
+diff -urNd apt-cacher-ng-0.3.8.orig/Makefile apt-cacher-ng-0.3.8/Makefile
+--- apt-cacher-ng-0.3.8.orig/Makefile 2009-04-11 13:25:45.000000000 +0400
++++ apt-cacher-ng-0.3.8/Makefile 2009-04-11 13:27:53.000000000 +0400
+@@ -47,12 +47,12 @@
+ # small build, even replacing libstdc++ with supc++ and gcc linking
+ in.acng: $(OBJSIN)
+ $(CC) -o $@ $(OBJSIN) -lsupc++ -Wl,--as-needed
+- strip $@
++# strip $@
+
+ apt-cacher-ng: $(OBJS)
+ $(CXX) -o $@ $(OBJS) -lpthread $(LDFLAGS) -lz -lbz2
+ @-test -d ../unstripped && cp $@ ../unstripped/$@.$$(dpkg-parsechangelog |grep ^Version: | cut -f2 -d' ') || true
+- strip $@
++# strip $@
+
+ else
+
+@@ -60,7 +60,7 @@
+
+ in.acng: $(OBJSIN) $(OBJS)
+ $(CXX) -o $@ acbuf.o client.o acfg.o filereader.o meta.o md5.o sha1.o aclogger.o -lz -lbz2 -Wl,--as-needed
+- strip $@
++# strip $@
+
+ apt-cacher-ng: $(OBJS)
+ $(CXX) -o $@ $(OBJS) -lpthread $(LDFLAGS) -lz -lbz2
+@@ -69,7 +69,7 @@
+ acngfs: $(OBJSFS)
+ $(CXX) -o acngfs $(OBJSFS) -Wl,--as-needed `pkg-config fuse --libs`
+ @-test -d ../unstripped && cp $@ ../unstripped/$@.$$(dpkg-parsechangelog |grep ^Version: | cut -f2 -d' ') || true
+- strip $@
++# strip $@
+
+ doc: doc/src/README.but doc/src/manpage.but doc/src/acngfs.but
+ mkdir -p doc/.build doc/html doc/man
diff --git a/net-misc/apt-cacher-ng/files/confd b/net-misc/apt-cacher-ng/files/confd
new file mode 100644
index 000000000..72e76de13
--- /dev/null
+++ b/net-misc/apt-cacher-ng/files/confd
@@ -0,0 +1,2 @@
+# Additional options that are passed to the Daemon.
+DAEMON_OPTS=" -c /etc/apt-cacher-ng "
diff --git a/net-misc/apt-cacher-ng/files/cron.daily b/net-misc/apt-cacher-ng/files/cron.daily
new file mode 100644
index 000000000..b5ea14367
--- /dev/null
+++ b/net-misc/apt-cacher-ng/files/cron.daily
@@ -0,0 +1,15 @@
+#!/bin/sh
+# Run the expire function of apt-cacher-ng non-interactively (unless errors
+# are detected).
+
+# optional, specify hostname to appear in error messages and links
+# HOSTNAME=externallyVisibleHostName
+# export HOSTNAME
+
+# optional, specify IP address to connect to
+# ACNGIP=10.0.1.3
+# export ACNGIP
+
+if test -r /usr/sbin/expire-caller.pl ; then
+ perl /usr/sbin/expire-caller.pl || echo Check error messages in /var/log/apt-cacher-ng/maint_*.log
+fi
diff --git a/net-misc/apt-cacher-ng/files/initd b/net-misc/apt-cacher-ng/files/initd
new file mode 100644
index 000000000..3097a69e2
--- /dev/null
+++ b/net-misc/apt-cacher-ng/files/initd
@@ -0,0 +1,32 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/rsync/files/rsyncd.init.d,v 1.5 2007/02/23 11:33:59 uberlord Exp $
+
+NAME="apt-cacher-ng"
+DAEMON="/usr/sbin/$NAME"
+RUNDIR="/var/run/$NAME"
+PIDFILE="$RUNDIR/$NAME.pid"
+SOCKETFILE="$RUNDIR/$NAME.socket"
+DAEMON_OPTS="$DAEMON_OPTS pidfile=$PIDFILE SocketPath=$SOCKETFILE foreground=0"
+
+depend() {
+ use net
+}
+
+start() {
+ ebegin "Starting $NAME"
+ start-stop-daemon --start --exec $DAEMON \
+ --chuid $NAME --group $NAME \
+ --pidfile $PIDFILE \
+ -- $DAEMON_OPTS
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping $NAME"
+ start-stop-daemon --stop --retry 15 --exec $DAEMON \
+ --pidfile $PIDFILE
+ rm -f $PIDFILE
+ eend $?
+}
diff --git a/net-misc/apt-cacher-ng/files/logrotate b/net-misc/apt-cacher-ng/files/logrotate
new file mode 100644
index 000000000..330f2b6b6
--- /dev/null
+++ b/net-misc/apt-cacher-ng/files/logrotate
@@ -0,0 +1,15 @@
+/var/log/apt-cacher-ng/*.log {
+ size 10M
+ missingok
+ rotate 12
+ compress
+ delaycompress
+ notifempty
+ create
+ postrotate
+ if [ -s /var/run/apt-cacher-ng/apt-cacher-ng.pid ] ; then
+ kill -s USR1 "$(cat /var/run/apt-cacher-ng/apt-cacher-ng.pid)"
+ fi
+ endscript
+}
+