summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/cloudvpn/cloudvpn-1.99.4.ebuild')
-rw-r--r--net-misc/cloudvpn/cloudvpn-1.99.4.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-misc/cloudvpn/cloudvpn-1.99.4.ebuild b/net-misc/cloudvpn/cloudvpn-1.99.4.ebuild
new file mode 100644
index 000000000..9a83f513e
--- /dev/null
+++ b/net-misc/cloudvpn/cloudvpn-1.99.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+inherit eutils autotools
+
+DESCRIPTION="secure mesh networking VPN"
+HOMEPAGE="http://e-x-a.org/"
+SRC_URI="http://e-x-a.org/releases/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=net-libs/gnutls-2.4"
+DEPEND="sys-devel/automake
+ ${RDEPEND}"
+
+src_compile() {
+ rm -r src/stunproxy #incomplete, don't bother with it.
+ ./autogen.sh
+ ./configure || die "configure failed!"
+ emake || die "emake failed!"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc README
+}