summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/igmpproxy/igmpproxy-0.1_beta2_p20090403.ebuild')
-rw-r--r--net-misc/igmpproxy/igmpproxy-0.1_beta2_p20090403.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-misc/igmpproxy/igmpproxy-0.1_beta2_p20090403.ebuild b/net-misc/igmpproxy/igmpproxy-0.1_beta2_p20090403.ebuild
new file mode 100644
index 000000000..70344dfc7
--- /dev/null
+++ b/net-misc/igmpproxy/igmpproxy-0.1_beta2_p20090403.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit autotools linux-info
+
+DESCRIPTION="Multicast Routing Daemon using only IGMP signalling (Internet Group Management Protocol)"
+HOMEPAGE="http://sourceforge.net/projects/igmpproxy"
+SRC_URI="http://dev.gentooexperimental.org/~idl0r/distfiles/${P}.tar.bz2"
+
+LICENSE="GPL-2 Stanford"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+CONFIG_CHECK="IP_MULTICAST IP_MROUTE"
+
+src_prepare() {
+ # create necessary files
+ eautoreconf
+}
+
+src_configure() {
+ # igmpproxy requires to be root
+ econf --bindir=/usr/sbin
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ newinitd "${FILESDIR}"/igmpproxy-init.d ${PN} || die
+ newconfd "${FILESDIR}"/igmpproxy-conf.d ${PN} || die
+}