summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/nanodc/nanodc-0.2.2.ebuild')
-rw-r--r--net-p2p/nanodc/nanodc-0.2.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-p2p/nanodc/nanodc-0.2.2.ebuild b/net-p2p/nanodc/nanodc-0.2.2.ebuild
new file mode 100644
index 000000000..3854483c9
--- /dev/null
+++ b/net-p2p/nanodc/nanodc-0.2.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit toolchain-funcs versionator
+
+DESCRIPTION="Ncurses DC++ client"
+HOMEPAGE="http://sourceforge.net/projects/nanodc/"
+SRC_URI="http://pouserinet.be/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+DEPEND="app-arch/bzip2
+ sys-libs/ncurses
+ dev-util/pkgconfig
+ dev-util/scons
+ sys-libs/zlib
+ >=dev-libs/libsigc++-2.0.0
+ >=dev-libs/glib-2.0.0"
+RDEPEND=${DEPEND}
+BIGVERSION=nanodc-$(get_version_component_range 1-2 )
+
+pkg_setup() {
+ if [[[ gcc-major-version ] != 4 ]]; then
+ eerror "We need at least gcc-4.0 to compile"
+ die "gcc-4 required"
+ fi
+}
+
+src_compile() {
+ cd "${WORKDIR}/${BIGVERSION}/trunk/src"
+ scons || die "scons failed!"
+}
+
+src_install() {
+ dobin "${WORKDIR}/${BIGVERSION}/trunk/src/nanodc"
+}