summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/libtifiles2/libtifiles2-1.1.0.ebuild')
-rw-r--r--sci-libs/libtifiles2/libtifiles2-1.1.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sci-libs/libtifiles2/libtifiles2-1.1.0.ebuild b/sci-libs/libtifiles2/libtifiles2-1.1.0.ebuild
new file mode 100644
index 000000000..ca9461d6b
--- /dev/null
+++ b/sci-libs/libtifiles2/libtifiles2-1.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="library for TI calculator files"
+HOMEPAGE="http://lpg.ticalc.org/prj_tilp/"
+SRC_URI="mirror://sourceforge/gtktiemu/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND=">=dev-libs/glib-2.6.0
+ sci-libs/libticables2
+ nls? ( virtual/libintl )"
+
+DEPEND="${RDEPEND}
+ >=sci-libs/libticonv-1.1.0
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+ econf $(use_enable nls) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS LOGO NEWS README ChangeLog docs/api.txt
+ dohtml docs/html/*
+}