summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-visualization/spyview/spyview-20091008.ebuild')
-rw-r--r--sci-visualization/spyview/spyview-20091008.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/sci-visualization/spyview/spyview-20091008.ebuild b/sci-visualization/spyview/spyview-20091008.ebuild
new file mode 100644
index 000000000..a90720dc8
--- /dev/null
+++ b/sci-visualization/spyview/spyview-20091008.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header $
+
+EAPI=2
+
+inherit base flag-o-matic eutils autotools multilib
+
+DESCRIPTION="Interactive plotting program"
+HOMEPAGE="http://kavli.nano.tudelft.nl/~gsteele/spyview/"
+SRC_URI="http://kavli.nano.tudelft.nl/~gsteele/${PN}/versions/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEPEND=">=dev-libs/boost-1.35
+ media-libs/netpbm
+ >=x11-libs/fltk-1.1.9:1.1
+ virtual/ghostscript"
+
+DEPEND="${COMMON_DEPEND}
+ sys-apps/groff"
+
+RDEPEND="${COMMON_DEPEND}
+ sci-visualization/gnuplot"
+
+S=${WORKDIR}/spyview-2009-10-08-16_58
+
+PATCHES=( "${FILESDIR}"/${P}-datadir.patch )
+
+src_prepare() {
+ base_src_prepare
+
+ append-cflags $(fltk-config --cflags)
+ append-cxxflags $(fltk-config --cxxflags) -I/usr/include/netpbm
+
+ # append-ldflags $(fltk-config --ldflags)
+ # this one leads to an insane amount of warnings
+
+ append-ldflags -L/usr/$(get_libdir)/fltk-1.1
+
+ eautoreconf
+}
+
+src_configure() {
+ econf --datadir=/usr/share/spyview
+}