summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'scripts')
-rwxr-xr-xscripts/echangelog8
1 files changed, 7 insertions, 1 deletions
diff --git a/scripts/echangelog b/scripts/echangelog
index 5ab9204e2..4b4bd8269 100755
--- a/scripts/echangelog
+++ b/scripts/echangelog
@@ -36,6 +36,11 @@ my %vcs = ( cvs => { diff => "cvs -f -U0 diff",
status => "git up",
add => "git add",
skip => 0,
+ entries => "wtf" },
+ nov => { diff => "echo M $(ls -tr *.ebuild | tail -n 1)",
+ status => "echo M $(ls -tr *.ebuild | tail -n 1)",
+ add => "",
+ skip => 0,
entries => "wtf" }
);
@@ -48,7 +53,8 @@ if ( -d "CVS" ) {
} elsif ( -d '.git' ) {
$vcs = "git";
} else {
- die "No CVS, .git, .svn directories found, what kind of repo is this?";
+ print STDERR "** NOTE: No CVS, .git, .svn directories found, cannot know modifications\n";
+ $vcs = "nov";
}
# Read the current ChangeLog