summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/evemu/files/evemu-1.0.10-werror.patch13
1 files changed, 8 insertions, 5 deletions
diff --git a/sys-apps/evemu/files/evemu-1.0.10-werror.patch b/sys-apps/evemu/files/evemu-1.0.10-werror.patch
index 333b2b767..5010b49e2 100644
--- a/sys-apps/evemu/files/evemu-1.0.10-werror.patch
+++ b/sys-apps/evemu/files/evemu-1.0.10-werror.patch
@@ -1,7 +1,7 @@
diff -u -r evemu-1.0.10-orig/configure.ac evemu-1.0.10/configure.ac
--- evemu-1.0.10-orig/configure.ac 2013-01-03 14:39:47.816749652 -0600
+++ evemu-1.0.10/configure.ac 2013-01-03 15:40:16.566917042 -0600
-@@ -35,9 +35,14 @@
+@@ -35,9 +35,17 @@
AC_MSG_WARN([xmlto or asciidoc not found - cannot create man pages without it])
fi
@@ -10,11 +10,14 @@ diff -u -r evemu-1.0.10-orig/configure.ac evemu-1.0.10/configure.ac
+AC_ARG_ENABLE([werror],
+ [AC_HELP_STRING([--disable-werror],
+ [build without gcc -Werror])],
-+ [],
-+ [WERROR="-Werror"])
++ [enable_werror=$enableval],
++ [enable_werror="yes"])
-+AC_SUBST(AM_CFLAGS,
-+ "-Wall -Wextra -pedantic $WERROR -std=gnu99 -D_GNU_SOURCE=1")
++AS_IF([test "x$enable_werror" = "xyes"],
++ [CFLAGS="-Werror $CFLAGS"])
++
++
++CFLAGS="-Wall -Wextra -pedantic -std=gnu99 -D_GNU_SOURCE=1 $CFLAGS"
AC_CONFIG_FILES([Makefile
src/Makefile