summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/ext3grep/ChangeLog24
-rw-r--r--sys-fs/ext3grep/Manifest5
-rw-r--r--sys-fs/ext3grep/ext3grep-0.10.1.ebuild41
-rw-r--r--sys-fs/ext3grep/files/gcc-4.3.patch170
-rw-r--r--sys-fs/ext3grep/metadata.xml10
5 files changed, 0 insertions, 250 deletions
diff --git a/sys-fs/ext3grep/ChangeLog b/sys-fs/ext3grep/ChangeLog
deleted file mode 100644
index 90f39f3ca..000000000
--- a/sys-fs/ext3grep/ChangeLog
+++ /dev/null
@@ -1,24 +0,0 @@
-# ChangeLog for sys-fs/ext3grep
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: $
-
- 13 May 2009; Christian Ruppert <idl0r@gentoo.org> ext3grep-0.10.1.ebuild:
- Removed unused eutils inherit, econf needs no die statement.
-
- 11 May 2009; Justin Lecher (jlec) <jlec@j-schmitz.net>
- ext3grep-0.10.1.ebuild:
- Make use of base eclass
-
-*ext3grep-0.10.1 (11 May 2009)
-
- 11 May 2009; Justin Lecher (jlec) <jlec@j-schmitz.net>
- -ext3grep-0.10.0.ebuild, +ext3grep-0.10.1.ebuild:
- version bump Thanks hanno for updated ebuild
-
- 12 Dec 2008; Thomas Sachau (Tommy[D]) <tommy@gentoo.org> metadata.xml:
- Fix metadata.xml
-
- 09 Dec 2008; Justin Lecher (jlec) <jlec@j-schmitz.net>
- +ext3grep-0.10.0.ebuild, +files/gcc-4.3.patch, +metadata.xml:
- Initial commit - related bug 246191
-
diff --git a/sys-fs/ext3grep/Manifest b/sys-fs/ext3grep/Manifest
deleted file mode 100644
index 35c93dd6d..000000000
--- a/sys-fs/ext3grep/Manifest
+++ /dev/null
@@ -1,5 +0,0 @@
-AUX gcc-4.3.patch 5338 RMD160 02bd66436fc309823c632abf0710d6d90fd7f4a6 SHA1 ffff4763ba1977577a102f0b7a00773b6304d903 SHA256 c1d887e26d7d5b19f7a3fe1653e711752259912c190f6b385f0dbb69c0523cc2
-DIST ext3grep-0.10.1.tar.gz 230939 RMD160 87fdc06cb98ab877d75e7d250dafb83df5c298ca SHA1 fbeb23d8416ed7a5642cba8acbab858d49b0e4a7 SHA256 162f038385a0166e29660e2a759e37f242eaeb7ccd5e6868c8804c71bcc2e3c0
-EBUILD ext3grep-0.10.1.ebuild 821 RMD160 6be25b056bf8405fe0377681ef2b7e540794e14b SHA1 3cf27d94d0fad65a9a7f575108b87b4d91661f04 SHA256 70ab0014faffac97d446afc1f14f631281ae6cb982f1729da136f7aa1ca555f7
-MISC ChangeLog 808 RMD160 301408afb18237f17b9bcbff8d16119f6eaa72c9 SHA1 eb4aefe8a49b396f7ac88d7039730c75cca4252c SHA256 69fd56d103ce440e6396198b53fc70f7a4ebeee0973eb7e8896b0bfe2c9b3ae6
-MISC metadata.xml 311 RMD160 3b578725b040cfd641529b2a6e96ea858cdc89dd SHA1 c5877275a44df0a3be795b9932796c45f4a70d5d SHA256 89ad924105e063aa2be6cbded89d22d13ba497d497ff052bb6dde1780abc5460
diff --git a/sys-fs/ext3grep/ext3grep-0.10.1.ebuild b/sys-fs/ext3grep/ext3grep-0.10.1.ebuild
deleted file mode 100644
index 61cb26df3..000000000
--- a/sys-fs/ext3grep/ext3grep-0.10.1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-inherit base
-
-DESCRIPTION="recover deleted files on an ext3 file system"
-HOMEPAGE="http://www.xs4all.nl/~carlo17/howto/undelete_ext3.html"
-SRC_URI="http://ext3grep.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="GPL-2"
-
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-IUSE="debug largefile libcwd pch"
-RDEPEND=""
-DEPEND="${RDEPEND}
- debug? ( libcwd? ( dev-cpp/libcwd ) )"
-
-PATCHES=( "${FILESDIR}"/gcc-4.3.patch )
-
-src_compile() {
- local myconf
-
- use debug && myconf="--disable-optimize"
-
- econf ${myconf} \
- $(use_enable libcwd) \
- $(use_enable debug) \
- $(use_enable pch) \
- $(use_enable largefile)
-
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
-
- dodoc NEWS README || die
-}
diff --git a/sys-fs/ext3grep/files/gcc-4.3.patch b/sys-fs/ext3grep/files/gcc-4.3.patch
deleted file mode 100644
index 160e4ff6f..000000000
--- a/sys-fs/ext3grep/files/gcc-4.3.patch
+++ /dev/null
@@ -1,170 +0,0 @@
---- src/custom.cc.orig 2008-11-09 18:02:00.000000000 +0100
-+++ src/custom.cc 2008-11-09 18:02:32.000000000 +0100
-@@ -42,6 +42,9 @@
- #include "get_block.h"
- #include "init_consts.h"
- #include "print_inode_to.h"
-+#include <sys/time.h>
-+#include <cstring>
-+#include <ctime>
-
- // The first part of this file was written and used for custom job:
- // recovering emails on a 40 GB partition that had no information
---- src/dir_inode_to_block.cc 2008-06-28 15:40:06.000000000 +0200
-+++ src/dir_inode_to_block.cc.new 2008-11-09 18:04:13.000000000 +0100
-@@ -40,6 +40,8 @@
- #include "print_inode_to.h"
- #include "directories.h"
- #include "journal.h"
-+#include <cstring>
-+#include <limits>
-
- //-----------------------------------------------------------------------------
- //
---- src/directories.cc 2008-10-16 00:45:31.000000000 +0200
-+++ src/directories.cc.new 2008-11-09 18:08:30.000000000 +0100
-@@ -33,6 +33,9 @@
- #include "indirect_blocks.h"
- #include "get_block.h"
- #include "directories.h"
-+#include <cstring>
-+#include <ctime>
-+#include <algorithm>
-
- //-----------------------------------------------------------------------------
- //
---- src/is_blockdetection.h 2008-07-11 02:23:37.000000000 +0200
-+++ src/is_blockdetection.h.new 2008-11-09 18:09:34.000000000 +0100
-@@ -31,6 +31,8 @@
-
- #include "inode.h" // Needed for InodePointer
-
-+#include <cstring>
-+
- // Return type of is_directory.
- enum is_directory_type {
- isdir_no = 0, // Block is not a directory.
---- src/commandline.cc 2008-10-18 03:06:35.000000000 +0200
-+++ src/commandline.cc.new 2008-11-09 18:20:54.000000000 +0100
-@@ -32,6 +32,8 @@
- #include "globals.h"
- #include "restore.h"
- #include "accept.h"
-+#include <ctime>
-+#include <limits>
-
- // Commandline options.
- bool commandline_superblock = false;
---- src/histogram.cc.orig 2008-11-09 18:41:42.000000000 +0100
-+++ src/histogram.cc 2008-11-09 18:41:30.000000000 +0100
-@@ -29,6 +29,7 @@
- #endif
-
- #include "commandline.h"
-+#include <cstring>
-
- //-----------------------------------------------------------------------------
- //
---- src/init_files.cc 2008-06-29 04:39:33.000000000 +0200
-+++ src/init_files.cc.new 2008-11-09 18:42:57.000000000 +0100
-@@ -33,6 +33,7 @@
- #include "globals.h"
- #include "forward_declarations.h"
- #include "journal.h"
-+#include <algorithm>
-
- //-----------------------------------------------------------------------------
- //
---- src/init_directories.cc.orig 2008-11-09 18:44:06.000000000 +0100
-+++ src/init_directories.cc 2008-11-09 18:43:49.000000000 +0100
-@@ -39,6 +39,7 @@
- #include "get_block.h"
- #include "journal.h"
- #include "dir_inode_to_block.h"
-+#include <limits>
-
- all_directories_type all_directories;
- inode_to_directory_type inode_to_directory;
---- src/indirect_blocks.cc 2008-10-20 20:45:29.000000000 +0200
-+++ src/indirect_blocks.cc.new 2008-11-09 18:45:45.000000000 +0100
-@@ -54,6 +54,7 @@
- #include "forward_declarations.h"
- #include "endian_conversion.h"
- #include "superblock.h"
-+#include <set>
-
- //-----------------------------------------------------------------------------
- //
---- src/journal.cc.orig 2008-11-09 18:47:39.000000000 +0100
-+++ src/journal.cc 2008-11-09 18:47:27.000000000 +0100
-@@ -37,6 +37,8 @@
- #include "indirect_blocks.h"
- #include "get_block.h"
- #include "commandline.h"
-+#include <algorithm>
-+#include <ctime>
-
- //-----------------------------------------------------------------------------
- //
---- src/inode.cc 2008-06-29 04:44:39.000000000 +0200
-+++ src/inode.cc.new 2008-11-09 18:49:52.000000000 +0100
-@@ -33,6 +33,7 @@
- #include "globals.h"
- #include "conversion.h"
- #include "inode.h"
-+#include <limits>
-
- #if USE_MMAP
- void inode_unmap(int group)
---- src/last_undeleted_directory_inode_refering_to_block.cc 2008-07-11 19:18:57.000000000 +0200
-+++ src/last_undeleted_directory_inode_refering_to_block.cc.new 2008-11-09 18:50:53.000000000 +0100
-@@ -29,6 +29,7 @@
- #include "is_blockdetection.h"
- #include "inode_refers_to.h"
- #include "journal.h"
-+#include <limits>
-
- // Return std::numeric_limits<int>::max() if the inode is still allocated
- // and refering to the given block, otherwise return the Journal sequence
---- src/ostream_operators.cc.orig 2008-11-09 18:53:05.000000000 +0100
-+++ src/ostream_operators.cc 2008-11-09 18:52:26.000000000 +0100
-@@ -31,6 +31,7 @@
- #include "endian_conversion.h"
- #include "superblock.h"
- #include "globals.h"
-+#include <ctime>
-
- //-----------------------------------------------------------------------------
- //
---- src/print_inode_to.cc 2008-10-17 03:27:15.000000000 +0200
-+++ src/print_inode_to.cc.new 2008-11-09 18:54:26.000000000 +0100
-@@ -30,6 +30,7 @@
- #include "FileMode.h"
- #include "globals.h"
- #include "print_symlink.h"
-+#include <ctime>
-
- void print_inode_to(std::ostream& os, Inode const& inode)
- {
---- src/restore.cc 2008-11-09 18:58:07.000000000 +0100
-+++ src/restore.cc.new 2008-11-09 18:58:17.000000000 +0100
-@@ -44,6 +44,9 @@
- #include "FileMode.h"
- #include "indirect_blocks.h"
- #include "print_symlink.h"
-+#include <sys/types.h>
-+#include <sys/stat.h>
-+#include <fcntl.h>
-
-
- #ifdef CPPGRAPH
---- src/show_journal_inodes.cc 2008-10-18 03:06:35.000000000 +0200
-+++ src/show_journal_inodes.cc.new 2008-11-09 18:58:59.000000000 +0100
-@@ -30,6 +30,7 @@
-
- #include "journal.h"
- #include "print_inode_to.h"
-+#include <limits>
-
- void show_journal_inodes(int inodenr)
- {
diff --git a/sys-fs/ext3grep/metadata.xml b/sys-fs/ext3grep/metadata.xml
deleted file mode 100644
index e955ed209..000000000
--- a/sys-fs/ext3grep/metadata.xml
+++ /dev/null
@@ -1,10 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <herd>maintainer-wanted</herd>
- <use>
- <flag name='largefile'>Add support for files greater then 2gb on x86</flag>
- <flag name='libcwd'>Debuging support</flag>
- </use>
-</pkgmetadata>
-