summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/ntfs3g-ar/ChangeLog4
-rw-r--r--sys-fs/ntfs3g-ar/ntfs3g-ar-2009.4.4_pre16.ebuild6
2 files changed, 7 insertions, 3 deletions
diff --git a/sys-fs/ntfs3g-ar/ChangeLog b/sys-fs/ntfs3g-ar/ChangeLog
index c96566a32..04e4e114c 100644
--- a/sys-fs/ntfs3g-ar/ChangeLog
+++ b/sys-fs/ntfs3g-ar/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 11 Aug 2009; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
+ ntfs3g-ar-2009.4.4_pre16.ebuild:
+ Simplify, build with external fuse, if not on linux
+
06 Aug 2009; P. Levine <plevine457@verizon.net>
ntfs3g-ar-2009.4.4_pre16.ebuild:
Fixups for pipe statements, fuse dependencies, and use flag handling.
diff --git a/sys-fs/ntfs3g-ar/ntfs3g-ar-2009.4.4_pre16.ebuild b/sys-fs/ntfs3g-ar/ntfs3g-ar-2009.4.4_pre16.ebuild
index dac8fd2d8..12e9ac372 100644
--- a/sys-fs/ntfs3g-ar/ntfs3g-ar-2009.4.4_pre16.ebuild
+++ b/sys-fs/ntfs3g-ar/ntfs3g-ar-2009.4.4_pre16.ebuild
@@ -19,7 +19,7 @@ IUSE="debug hal suid"
RDEPEND="hal? ( sys-apps/hal )
!kernel_linux? ( sys-fs/fuse )
- kernel_linux? ( fuse? ( sys-fs/fuse ) )"
+ fuse? ( sys-fs/fuse )"
DEPEND="${RDEPEND}"
@@ -37,7 +37,7 @@ pkg_setup() {
src_compile() {
local myconf
- use kernel_linux && use fuse && myconf="--with-fuse=external"
+ ( !kernel_linux || use fuse ) && myconf="--with-fuse=external"
econf \
--docdir="/usr/share/doc/${PF}" \
@@ -70,7 +70,7 @@ pkg_postinst() {
ewarn "http://pagesperso-orange.fr/b.andre/advanced-ntfs-3g.html"
ewarn
- if ! use kernel_linux || use kernel_linux && use fuse ; then
+ if ! use kernel_linux || use fuse ; then
ewarn
ewarn "ntfs-3g has been built with external FUSE support."
ewarn "If your system's FUSE package gets updated please rebuild ntfs-3g,"