summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/ccs-sources/ccs-sources-2.6.32-r8.ebuild')
-rw-r--r--sys-kernel/ccs-sources/ccs-sources-2.6.32-r8.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys-kernel/ccs-sources/ccs-sources-2.6.32-r8.ebuild b/sys-kernel/ccs-sources/ccs-sources-2.6.32-r8.ebuild
new file mode 100644
index 000000000..fa062e43a
--- /dev/null
+++ b/sys-kernel/ccs-sources/ccs-sources-2.6.32-r8.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="13"
+
+inherit eutils kernel-2
+detect_version
+detect_arch
+
+CCS_TGP="ccs-patch-1.7.2-20100412"
+CCS_TGP_SRC="mirror://sourceforge.jp/tomoyo/43375/${CCS_TGP}.tar.gz"
+
+DESCRIPTION="TOMOYO Linux sources for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
+HOMEPAGE="http://tomoyo.sourceforge.jp/index.html.en"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} ${CCS_TGP_SRC}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RDEPEND="sys-apps/ccs-tools"
+
+K_EXTRAEINFO="Before booting with TOMOYO enabled kernel, you need to
+run this command to initialize TOMOYO policies:
+# /usr/lib/ccs/init_policy.sh"
+
+src_unpack() {
+ kernel-2_src_unpack
+
+ cd "${WORKDIR}"
+ unpack "${CCS_TGP}.tar.gz"
+ cp -dpR security include "${S}" || die
+
+ if [ -f "${FILESDIR}/${PF}.patch" ]; then
+ cd "${WORKDIR}/patches/"
+ epatch "${FILESDIR}/${PF}.patch"
+ fi
+
+ cd "${S}"
+ epatch "${WORKDIR}/patches/ccs-patch-${PV}.diff"
+}