summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-power/phc-intel/phc-intel-0.3.2.11.ebuild')
-rw-r--r--sys-power/phc-intel/phc-intel-0.3.2.11.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sys-power/phc-intel/phc-intel-0.3.2.11.ebuild b/sys-power/phc-intel/phc-intel-0.3.2.11.ebuild
new file mode 100644
index 000000000..6401e38de
--- /dev/null
+++ b/sys-power/phc-intel/phc-intel-0.3.2.11.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit linux-info linux-mod
+
+DESCRIPTION="Processor Hardware Control for Intel CPUs"
+HOMEPAGE="http://www.linux-phc.org/"
+SRC_URI="http://www.linux-phc.org/forum/download/file.php?id=92 -> ${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${P%.*}-${P##*.}"
+
+CONFIG_CHECK="~!X86_ACPI_CPUFREQ"
+ERROR_X86_ACPI_CPUFREQ="CONFIG_X86_ACPI_CPUFREQ has to be configured to Module or Not set to enable the replacement of acpi-cpufreq with phc-intel."
+
+MODULE_NAMES="phc-intel(misc:)"
+BUILD_PARAMS="KERNELSRC=\"${KERNEL_DIR}\" -j1"
+BUILD_TARGETS="prepare all"
+
+src_install() {
+ linux-mod_src_install
+ dodoc README || die
+}