summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/daemon/ChangeLog8
-rw-r--r--sys-process/daemon/Manifest4
-rw-r--r--sys-process/daemon/daemon-0.6.3.ebuild35
-rw-r--r--sys-process/daemon/metadata.xml5
4 files changed, 52 insertions, 0 deletions
diff --git a/sys-process/daemon/ChangeLog b/sys-process/daemon/ChangeLog
new file mode 100644
index 000000000..76abcbf5b
--- /dev/null
+++ b/sys-process/daemon/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for sys-process/daemon
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 25 Aug 2007; Federico Ferri (federico__) <mescalinum@gmail.com>
+ +metadata.xml, +daemon-0.6.3.ebuild:
+ New Ebuild for bug 91030
+
diff --git a/sys-process/daemon/Manifest b/sys-process/daemon/Manifest
new file mode 100644
index 000000000..93b933642
--- /dev/null
+++ b/sys-process/daemon/Manifest
@@ -0,0 +1,4 @@
+DIST daemon-0.6.3.tar.gz 396724 RMD160 4aef0e16bcd426613112d1d200ffd9643a7a206a SHA1 7d4cde72b4dc20a20f82a3994aa7d1b54b3e1952 SHA256 2539c1222db851c80b8ccd3569294f9137063cfd9a262e6407be11ea55901260
+EBUILD daemon-0.6.3.ebuild 694 RMD160 26bb30af71b70083f93d0309be4c2613ba3b7d7c SHA1 c3f262f855215d40dfa884fcb1dae74a42c94fb8 SHA256 15a939ae4187883e24ad927a379ee139f0be9ed04dcd40a3d5d8452f91d6e56a
+MISC ChangeLog 252 RMD160 618d5b23e4e6638fbe87a4618d3b614dc9ab2dc2 SHA1 ff4d8a937a37aaeff1791de0a629c156ad8a5185 SHA256 7e9ea36490ee1724afaad15283e056603d260191616f7e4c7f793c24e8625e34
+MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/sys-process/daemon/daemon-0.6.3.ebuild b/sys-process/daemon/daemon-0.6.3.ebuild
new file mode 100644
index 000000000..47718756e
--- /dev/null
+++ b/sys-process/daemon/daemon-0.6.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit toolchain-funcs
+
+DESCRIPTION="Daemon turns other process into daemons, respawning automatically"
+HOMEPAGE="http://www.libslack.org/daemon/"
+SRC_URI="http://libslack.org/daemon/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 -amd64"
+IUSE=""
+RESTRICT="test"
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i -e '/strip/d' rules.mk
+}
+
+src_compile() {
+ ./config
+ emake CC="$(tc-getCC)" AR="$(tc-getAR)" RANLIB="$(tc-getRANLIB)" \
+ CCFLAGS="${CFLAGS}" PREFIX="/usr"
+}
+
+src_install() {
+ emake PREFIX="${D}/usr" install
+ dodoc README
+}
diff --git a/sys-process/daemon/metadata.xml b/sys-process/daemon/metadata.xml
new file mode 100644
index 000000000..7e3286984
--- /dev/null
+++ b/sys-process/daemon/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>maintainer-wanted</herd>
+</pkgmetadata>