summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/davical/davical-1.0.2.ebuild')
-rw-r--r--www-apps/davical/davical-1.0.2.ebuild78
1 files changed, 78 insertions, 0 deletions
diff --git a/www-apps/davical/davical-1.0.2.ebuild b/www-apps/davical/davical-1.0.2.ebuild
new file mode 100644
index 000000000..bdfcd51a8
--- /dev/null
+++ b/www-apps/davical/davical-1.0.2.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit depend.php webapp
+
+DESCRIPTION="A CalDAV and CardDAV Server"
+HOMEPAGE="http://davical.org/"
+SRC_URI="http://debian.mcmillan.net.nz/packages/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="doc? ( dev-php/PEAR-PhpDocumentor )"
+RDEPEND="app-admin/pwgen
+ || ( <dev-lang/php-5.3[pcre,pdo,postgres,xml]
+ >=dev-lang/php-5.3[pdo,postgres,xml] )
+ dev-perl/DBI
+ dev-perl/DBD-Pg
+ dev-perl/yaml
+ >=dev-php/awl-0.51
+ www-servers/apache"
+
+need_php5
+need_httpd
+
+src_prepare() {
+ epatch "${FILESDIR}/awl_location.patch"
+ epatch "${FILESDIR}/inc_path.patch"
+}
+
+src_compile() {
+ if use doc ; then
+ einfo "Generating documentation"
+ phpdoc -q -c "docs/api/phpdoc.ini"\
+ || die "Documentation failed to build"
+ fi
+ emake built-po || die "emake failed"
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc-php INSTALL README debian/README.Debian \
+ testing/README.regression_tests TODO debian/changelog \
+ || die "dodoc failed"
+
+ einfo "Installing web files"
+ insinto "${MY_HTDOCSDIR}"
+ doins -r htdocs/* htdocs/.htaccess || die "doins failed"
+
+ einfo "Installing main files and i18n"
+ insinto "${MY_HOSTROOTDIR}/${PN}"
+ doins -r inc locale || die "doins failed"
+ rm -f "${D}/${MY_HOSTROOTDIR}/${PN}/inc/always.php.in"
+
+ einfo "Installing sql files"
+ insinto "${MY_SQLSCRIPTSDIR}"
+ doins -r dba/* || die "doins failed"
+
+ if use doc ; then
+ einfo "Installing documentation"
+ dohtml -r docs/api/ docs/website/ || die "dohtml failed"
+ fi
+
+ insinto /etc/${PN}
+ doins config/* "${FILESDIR}/vhost-example" \
+ || die "newins failed"
+
+ webapp_postinst_txt en "${FILESDIR}/postinstall-en.txt"
+ webapp_src_install
+
+ fperms +x "${MY_SQLSCRIPTSDIR}/create-database.sh"
+ fperms +x "${MY_SQLSCRIPTSDIR}/update-davical-database"
+}